 | 圆角矩形: 工程传输/工程维护
圆角矩形: 新建工程


RemoteHMI快速入门

定义

本章介绍RemoteHMI组态软件的安装，包括组态程序安装以及设备驱动安装，基本功能和主要特点，并对软件系统的构成和各个组成部分的功能进行详细地说明，帮助认识RemoteHMI组态软件系统总体的结构框架；同时介绍RemoteHMI系统运行软件需求，以及RemoteHMI的安装过程和工作环境，学习使用RemoteHMI组态软件并创建应用工程。

目录

l 了解RemoteHMI

l RemoteHMI运行的系统需求

l RemoteHMI的安装过程

l RemoteHMI的卸载过程

l RemoteHMI的运行

l RemoteHMI窗口操作

l RemoteHMI基本操作


远程客户端使用指南

定义

远程客户端，包括PC客户端，手机客户端（Android,IOS），通过客户端

可以显示HMI界面，操作控制HMI，查看HMI状态，PLC状态,实现数据的上、

下载等。本节主要介绍远程客户端的使用以及客户端的各个功能的作用。网页客户

端网址为 http://www.samkoonyun.com/。

在使用客户端功能时，首先得确保PC上已经安装了RemoteHMI软件，如果提

示dllServer.exe服务未开启，需要手动开启此服务。如何开启dllServer.exe服务？

目 录

l 注册

l 登录

l 主界面

l 添加设备

l 删除设备

l 忘记密码

l dllServer.exe服务


注册

定义

n 注册

注册一个账号，才可以实现登录，如图1-1所示：

图1-1 注册界面

属性概述以及操作

ü 请输入用户名：输入一个自定义的用户名，不能为中文，不能为空，。

ü 请输入密码：输入一个自己设定密码，密码长度为6-16位，不能为中文，不能为空。

ü 请重复输入密码：再一次输入自己设定的密码，不能为空。

ü 注册：用户名，密码都准确无误输入之后，点击“注册”，即可注册成功。

如果用户名，密码都输入，点击“注册”，提示错误，有可能是以下错误：

n 无效的用户：填写了一个不符合规范的用户名或填写了一个已存在的用户名。

n 网络错误：点击“注册”时，可能碰巧网络中断或网络信号不好，就会导致此错误的发生。

n 操作超时：执行注册功能的时候，在此页面操作了很久，就会出现此错误。


登录

定义

n 登录

进入主界面之前，需要先登录，才能进去，登录界面如图2-1所示：

图2-1 登录界面

属性概述以及操作

ü 请输入登录用户名：输入已存在或者已经注册好的用户名，不能为空。

ü 请输入登录密码：输入匹配的登录密码。

ü 登录：准确的输入登录用户名，登录密码之后，点击“登录”，即可实现登录，登录进入主界面。

如果登录名，登录密码都输入，点击“登录”，提示错误，有可能是以下错误：

n 无效的用户：填写了一个不存在的用户名。

n 密码错误：填写了一个已存在的用户名，但用户登录密码填写错误。

n 网络错误：点击“登录”时，可能碰巧网络中断或网络信号不好，就会导致此错误的发生。

n 操作超时：执行登录功能的时候，在此页面操作了很久，就会出现此错误。

备注：SK用户登录的时候，没有进入VNC界面的功能，AK用户登录的并且机型型号带“-R”才有进入VNC界面功能。


主界面

定义

n 主界面

主界面可以看到在线或者离线的S/N设备，可以刷新界面，可以搜索设备，注销登录，设置每页显示的数量，添加设备，

如图6-1所示：

图6-1 主界面

属性概述以及操作

ü 刷新：点击“刷新”按钮，可以刷新列表。

ü 搜索：输入要搜索的设备ID，点击“搜索”，搜索结果会显示在列表上，点击搜索框的删除号，可以清空搜索框的搜索内容，

如图6-2所示：

图6-2 搜索结果

ü 注销登录：点击“注销”，就可以退出当前用户的登录，并返回到登录界面。

ü 每页显示数量：点开下拉列表，选择每页要显示的数量，即可设置，如图6-3所示：

图6-3 每页显示数量

ü 添加设备：点击“添加设备”按钮，就会弹出一个添加设备的界面,可以添加自己想监视的设备，如图6-4:

图6-4 添加设备界面


添加设备

定义

n 添加设备

添加设备是添加自己想监视的S/N设备，如图3-1所示：

图3-1 添加设备界面

属性概述以及操作

ü 请输入S/N：输入要添加的S/N码。

ü 发送验证码：点击“发送验证码”，会以弹出提示框的方式发送六位随机数字到填写的S/N码的设备上。

ü 请输入验证码：输入S/N码接收到的六位随机数字的验证码。

ü 确认：准确的输入S/N码，验证码，点击“确认”，就可以添加该S/N码的设备到主界面的列表上。

ü 取消：点击“取消”，终止添加设备功能。

如果S/N码，验证码都输入，点击“确认”，提示错误，有可能是以下错误：

n 无效的对象：填写了一个不符合规范的S/N码，或者填写了一个不存在的S/N码，亦或者是填写

的S/N码设备没有连接电源，没能连接到服务器。

n 验证码错误：填写了正确的S/N码，但验证码填写错误。

n 网络错误：点击“确认”时，可能碰巧网络中断或网络信号不好，就会导致此错误的发生。

n 操作超时：执行添加设备功能的时候，在此页面操作了很久，就会出现此错误。


删除设备

定义

n 删除设备

对于不想监视的设备，可以进行删除，如图5-1所示：

图5-1 删除界面

属性概述以及操作

ü 删除：点击每一行列表中的“删除”，即可删除不想监视的设备。

如果点击“删除”，提示错误，有可能是以下错误：

n 网络错误：点击“删除”时，可能碰巧网络中断或网络信号不好，就会导致此错误的发生。

n 操作超时：执行删除功能的时候，在此页面操作了很久，就会出现此错误。


忘记密码

定义

n 忘记密码

忘记密码是在只记得用户名和该用户名下绑定的其中一个S/N码，才能实现的功能，如图4-1所示：

图4-1 忘记密码功能界面

ü 请输入要获取密码的用户名：输入要获取密码的用户名，不能为空。

ü 请输入此用户名已绑定的产品SN号：输入此用户已绑定的产品S/N码，不能为空。

ü 发送密码：获取密码的用户名，此用户名已绑定的产品SN号都准确输入之后，点击“发送密码”，

在输入的S/N码设备中，通过弹出提示框的方式，显示您忘记的密码是多少。

ü 返回登录：点击“返回登录”，可以返回到登录界面。

如果获取密码的用户名，此用户名已绑定的产品SN号都输入，点击“发送密码”，提示错误，有可能是以下错误：

n 无效的用户：填写了一个不符合规范的用户名或填写了一个不存在的用户名。

n 无效的对象：填写了一个不符合规范的S/N码，或者填写了一个未和该用户绑定的S/N码，亦或者是填写

的S/N码设备没有连接电源，没能连接到服务器。

n 网络错误：点击“注册”时，可能碰巧网络中断或网络信号不好，就会导致此错误的发生。

n 操作超时：执行注册功能的时候，在此页面操作了很久，就会出现此错误。


dllServer.exe服务

定义

n dllServer.exe服务

在使用客户端功能时，如果提示dllServer.exe服务未开启，需先手动打开此服务。在RemoteHMI

安装目录下可以打开此服务，如图6-1所示：

图6-1 打开dllServer.exe服务界面

双击打开或者右键点击“打开”就可以启动该服务


关于RemoteHMI

RemoteHMI工业自动化组态编辑软件是一种用于快速构造和生产嵌入式计算机监控系统的组态软件。采用目前先进的计算机软件技术，以窗口为单位，构造用户运行系统的图形界面，通过对现场数据的采集处理，以动画显示、报警处理、流程控制和报表输出等多种方式向用户提供解决实际工程问题的方案，在自动化领域有着广泛的应用。

产品特点：


RemoteHMI的运行

定义

RemoteHMI.exe在安装完成后，会在桌面上放置运行快捷方式，

如图2-17所示：

图2-17 桌面快捷图标

双击桌面上的快捷方式，或者单击开始菜单中RemoteHMI程序组的RemoteHMI.exe运行组态

软件，运行界面如下图2-18：

图2-18软件运行画面


编辑界面及系统构成

定义

RemoteHMI编辑接口简洁友好，易学易用。本节介绍RemoteHMI的

组态画面以及软件的各个功能按钮。

目 录

l RemoteHMI的编辑界面特点

l RemoteHMI的系统构成


RemoteHMI编辑界面

定义

RemoteHMI组态软件是深圳市显控自动化技术有限公司Samkoon触摸屏系列的画面开发系统，

是集成化的开发环境，有很丰富而且很强大的开发功能。RemoteHMI利用了Windows系统的优点，

界面一致性好，简单，菜单的布局接近与Windows操作习惯，易学易用，工程设计人员可以在

RemoteHMI中开发适合自己工程使用的组态。开发界面和各个功能区域如图2-27所示：

图2-27 软件界面区域

· 标题栏：显示RemoteHMI的版本名称。

· 菜单条：显示RemoteHMI的各项命令的菜单，这些菜单均是下拉式菜单。

· 工具按钮：一些命令的快捷方式按钮。显示文件，编辑，绘图等功能的相应按钮。

· 画面区域窗口：工程设计人员进行组态，编辑图形对象的窗口。

· 工程管理器：触摸屏的通讯连接、参数设置、画面管理、报警设置、配方设置、

历史数据收集器设置的树形菜单。

· 信息输出窗口：工程设计人员进行组态编辑和编译时，输入，输出信息的提示，

错误提示等不同的信息提示。

· 状态栏：当前组态状态。包括鼠标的坐标，控件类型，控件坐标，控件大小等一系列

的状态。

目 录

l 菜单

l 工具栏

l 工程管理器


菜单

定义

RemoteHMI组态画面编辑软件的菜单栏为使用者提供了丰富的菜单选项，几乎所有的工程

组态所需要到的工具命令和编辑命令都可以在菜单栏里找到。菜单栏包括文件菜单，编辑菜单，

查看菜单，物件菜单，下载菜单，帮助菜单和语言菜单，并且还包括有右键菜单。

菜单栏如下图2-28所示：

图2-28 “文件”菜单

目 录

l 文件菜单

l 编辑菜单

l 查看菜单

l 物件菜单

l 下载菜单

l 帮助菜单

l 语言选择


帮助菜单

定义

n 帮助菜单

使用该“帮助”菜单可以调出RemoteHMI的帮助文档和RemoteHMI的版本号和版权说明。

如图2-36所示：

图2-36 帮助菜单

Ø 关于：RemoteHMI的版本号和版权说明如图2-37所示：

图2-37版本号说明

Ø 帮助：打开RemoteHMI的帮助文档。


编辑菜单

定义

n 编辑菜单

“编辑”菜单是一组用于对画面及画面的文字，图形等内容进行编辑和辅助的命令。有撤消，

恢复，剪切，复制，多重复制，粘贴，删除，对齐，层次。菜单条中显示为灰色的

命令表示在当前操作下，该命令无效，要使用这些命令，首先应选择要进行编辑的图形对象，然后选择

“编辑”菜单中的对应的命令，“编辑”菜单中有些命令是组命令，若是组命令，则该命令所在的行的

右边会有一个小三角形，表示这是一个组命令，并且每个命令都有对应的快捷键。此菜单是一个下拉式

的菜单，如图2-30所示：

图2-30 “编辑”菜单

ü 撤销：快捷键Ctrl+Z，使用该命令可以取消上次操作命令，使用该命令可以取消您最近的一次操作。

ü 恢复：快捷键Ctrl+Y，使用该命令可以恢复上次操作命令，使用该命令可以恢复您最近的一次操作。

ü 剪切：快捷键Ctrl+X，使用该命令可以删除您选择的图形对象，并把这些图形对象复制到粘贴缓冲区中。

ü 复制：快捷键Ctrl+C，使用该命令可以复制您选择的图形对象到粘贴缓冲区中。

ü 多重复制：使用该命令可以向水平和垂直方向复制用户所需的多个所选图形，并可以

使地址依次递增0—255个单位。

ü 粘贴：快捷键Ctrl+V，使用该命令可以把粘贴缓冲区中的图形对象复制到当前画面中。

ü 删除：快捷键Del，使用该命令可以把您选择的图形对象从画面中删除。

ü 对齐：使用该命令可以使选定的多个对象(两个以上)按照所选的对齐方式对齐。对齐方式

包括上对齐，下对齐，垂直居中，左对齐，右对齐，水平居中。

ü 层次：使用该命令可以把选定的对象放置到不同的画面层次里面。可以选择的层次项包括

拿到最上层，拿到上一层，放到最下层，放到下一层。

提示：在使用组合键时，切勿把需要触摸的对象进行组合操作，否则下载到触摸屏后无法触摸。用户需要

叠加触摸对象时建议使用层次选项。


查看菜单

定义

n 查看菜单

该菜单主要用于显示工程中操作框。有调整分辨率，设置连接密码，设置设备名选项。如下图所示：

ü 调整分辨率：调整触摸屏的宽度和高度。

ü 进入画面密码修改：进入画面后需输入密码才能查看画面，密码长度范围6-16，如下图

验证成功，则可以进入组态界面。

ü 设置设备名：在客户端设备列表中显示该设备名称，如果没设置别名，则显示S/N 码，连接设备名长度范围1-20，如下图


鼠标右击菜单

定义

n 鼠标右击菜单

为了方便使用者操作，设置了“右键”菜单，这也符合 大多数用户的操作习惯和Windows的风格。

组态使用的很多功能都可以在这里找得到。“右键”菜单的命令有属性，粘贴，剪切，复制，删除，

多重复制，移到最上层，移到上一层，移到最下层，移到下一层。

“右键”菜单如下图2-39所示。

图2-39 右键菜单

ü 属性：使用该命令可以打开控件(当前选择单一对象)的属性窗口和打开画面(当前未选择任何对象)

的属性窗口。

ü 粘贴：快捷键Ctrl+V，使用该命令可以把粘贴缓冲区中的图形对象复制到当前画面中。

ü 剪切：快捷键Ctrl+X，使用该命令可以删除您选择的图形对象，并把这些图形对象复制到粘贴缓冲区中。

ü 复制：快捷键Ctrl+C，使用该命令可以复制您选择的图形对象到粘贴缓冲区中。

ü 删除：快捷键Ctrl+Del，使用该命令可以把您选择的图形对象从画面中删除。

ü 多重复制：快捷键Ctrl+D，使用该命令可以向水平和垂直方向复制用户所需的多个所选图形，并可以

使地址依次递增0—255个单位。

ü 移到最上层：移到最上层命令，使用该命令可以把你选择的图形对象置于画面的最上层。

ü 移到上一层：移到上一层命令，使用该命令可以把你选择的图形对象上移一层。

ü 移到最下层：移到最下层命令，使用该命令可以把你选择的图形对象置于画面的最下层。

ü 移到下一层：移到下一层命令，使用该命令可以把你选择的图形对象下移一层。

提示：在使用组合键时，切勿把需要触摸的对象进行组合操作，否则下载到触摸屏后无法触摸。用户需要叠

加触摸对象时建议使用层次选项。


文件菜单

定义

n 文件菜单

“文件”菜单具有新建工程(N)，打开工程(O)，关闭工程，保存，最近打开工程。

若某项的字体为灰色，则表明当前该操作在当前环境下无效。打开文件菜单方法，单击组态软件左

上角的“文件”，弹出下拉式文件菜单工具条，如图2-29所示：

图2-29 “文件”菜单

ü 新建工程：快捷键Ctrl+N，使用该命令可以建立一个空白的工程。

ü 打开工程：快捷键Ctrl+O，使用该命令可以打开用户已建立过和保存在Windows下的工程

文件，可以打开后缀名为.shm的工程组态文件。

ü 关闭工程：使用该命令可以关闭当前工程画面组态，而不退出AKWorkshop组态软件。

ü 保存：快捷键Ctrl+S，使用该命令可以保存当前已改动的画面组态，文件名和保存路径默

认为原来的文件名和保存路径。

ü 最近打开的工程：显示最近打开的工程名字，点击打开该工程

ü 压缩/解压：使用该命令可以压缩/解压工程


物件菜单

定义

n 物件菜单

“物件”菜单是一组触摸键和功能键，包括有：开关（位按钮、字按钮、画面按钮、功能按钮、

指示灯），数据显示，表格，静态文本，柱状图，XY趋势图，饼图，图片。“物件”菜单对应工具栏的第四排，如图2-32所示：

图2-32 “物件”菜单

ü 数值显示：使用该命令可以在当前画面上画出一个用于显示所监视地址数值的数显框。

ü 开关位按钮：使用该命令可以在当前画面设置一个对连接设备进行位操作的触摸键。包括对位的

置位，复位，点动，交替操作。

ü 开关字按钮：使用该命令可以在当前画面设置一个对连接设备进行字操作的触摸键。包括对字的

设定常数，输入数值，输入密码，加，减操作。

ü 开关画面按钮：画面按钮主要用于画面的切换、改变用户等级和弹出窗口等操作。

ü 开关功能按钮：功能开关按钮在整个触摸屏中是很重要的控件，通过功能按钮可以很方便快捷

的达到各种功能要求。

ü 开关指示灯：位指示灯可以用来监视的所连接的设备的位触点ON/OFF状态，并可以在触摸屏上以

相应的ON/OFF 状态来显示位触点的状态。

ü 表格：使用该命令可以在当前画面上画出一个用于显示各种不同数据的表格。

ü 静态文本：使用该命令可以在当前画面上画出一个用于显示文字的文本框。

ü 柱状图：使用该命令可以在当前画面上画出一个以柱状形式显示数据增减的柱状图控件。

ü XY趋势图：XY趋势图以曲线显示形式，展示出数据的变化趋势。

ü 饼图：根据数据比例，以扇形方式显示大小。

ü 图片：用于显示静态图片。


下载菜单

定义

n 下载菜单

“下载”菜单用于编译和下载组态工程，该菜单有两个命令，分别是下载工程和打包。使用

USB电缆连接PC和触摸屏后，可以通过USB下载把组态工程下载到触摸屏中，下载之前必须

先编译组态工程。如图2-35所示：

图2-35 “下载”菜单

ü 下载工程：使用该命令将设定好的组态下载到屏里，可在屏内的android系统来操控控件。

首先弹出保存对话框，如果有修改又没有保存是不能下载组态的

弹出对话框点是以后，就进入下载页面，如下

分三种方式下载：

1. 使用ＵＳＢ下载：插上ＵＳＢ接口，即可将组态直接下载到屏中进行操作。

2. 使用以太网下载：通过ＩＰ地址下载。

3. 下载到Ｕ盘：插入Ｕ盘，选择好要储存的位置，点击下载，生产.akz格式文件

ü 打包：将画面使用的图片和控件的数据库打包压缩为App.akz，如果有修改又没有保存也是不能进行打包的。

弹出对话框以后，就进入打包页面，如下图

然后点击浏览选择打包路径，如下图

点击打包，打包完成。如下图

ü 运行：将当前的工程通过用户登录，远程控制工程。


语言菜单

定义

n 语言菜单

该菜单实现软件的中英文切换。如下图2-38所示：

图2-38 语言选择

选择“中文”，则该软件是简体中文版；选择“英文”则该软件是英文版软件。


工程管理器

定义

工程管理器如下图2-43所示：

图2-43窗口画面

目录

l COM配置

l 画面


COM配置

操 作

在工程配置树形菜单中选择 [image] ，双击点开“COM配置”，COM配置有项目

选择，连接接口，设备厂家，设备型号，站号，IP设置，组1配置以及组2配置。根据你所需的

配置，选择项目，项目有远程客户端（如图1），远程控制器（如图2）。

图1 远程客户端对话框

图2 远程控制器对话框

目录

l 远程客户端配置

l 远程控制器配置


远程客户端配置

通信连接

通信连接对话框用于设定触摸屏的通信口的通信参数，只有设定了正确的通信参数才能保证

触摸屏与PLC的正确通信，具体的通信参数由要连接的PLC的型号决定。

ü  连接接口：通信串口的名称。

ü  设备厂家：设备驱动的厂商。

ü  设备型号：该厂商的产品系列。

ü  站号：定义设备型号名称。

图3-2 通信连接对话框

上图3-2即为通信口设定对话框，工程设计人员可以在此对话框中根据自己所采用连接设备的

类型选择相应的设备服务。NET链接，就在“连接接口”中选择“NET”选项。

Birne ： AK-7，AK-10.2有两个COM口，

暂时只连接一台PLC时，由使用的COM口决定。AK-3.5A，

AK-4, AK-4.3, AK-4.3, AK-5只有一个COM口，只需设定COM1口。

Birne ：组态时也可以在工程管理器的连接中设定通讯属性，其他参数也在通讯属性里设定。


远程控制器配置

通信连接

通信连接对话框用于设定触摸屏的通信口的通信参数，只有设定了正确的通信参数才能保证

触摸屏与PLC的正确通信，具体的通信参数由要连接的PLC的型号决定。

ü  连接接口：通信串口的名称。

ü  设备厂家：设备驱动的厂商。

ü  设备型号：该厂商的产品系列。

ü  站号：定义设备型号名称。

ü  IP设置：设置远程通信控制器的网络参数。

ü  组1配置：设置组1波特率、数据位、校验、停止位和超时时间配置。

ü  组2配置：设置组2波特率、数据位、校验、停止位和超时时间配置。

图3-2 通信连接对话框

上图3-2即为通信口设定对话框，工程设计人员可以在此对话框中根据自己所采用连接设备的

类型选择相应的设备服务。

Birne ： AK-7，AK-10.2有两个COM口，

暂时只连接一台PLC时，由使用的COM口决定。AK-3.5A，

AK-4, AK-4.3, AK-4.3, AK-5只有一个COM口，只需设定COM1口。

Birne ：组态时也可以在工程管理器的连接中设定通讯属性，其他参数也在通讯属性里设定。


画面

目录

l 新增画面

l 画面属性

l 删除画面

l 复制画面


工具栏

定义

RemoteHMI组态画面编辑软件提供了六种工具栏，包含有“标准工具栏、层次工具栏、

对齐工具栏、标准状态栏、信息输出窗口、控件工具栏”等工具栏。

目 录

l 标准工具栏

l 层次工具栏

l 对齐工具栏

l 标准状态栏

l 信息输出窗口

l 控件工具栏


标准工具栏

定义

工具栏如下图2-40所示：

图2-40 标准工具栏

如上图，工具条的各个命令与菜单中的内容是互相对应的，各个按钮的功能分别是：

：新建工程，快捷键Ctrl+N，使用该命令可以建立一个空白的工程。

：打开工程，快捷键Ctrl+O，使用该命令可以打开用户已建立过和保存在Windows下的工程文件，

可以打开后缀名为.shm的工程组态文件。

：保存命令，快捷键Ctrl+S，使用该命令可以保存当前已改动的画面组态，文件名和保存路径默

认为原来的文件名和保存路径。

：撤销命令，快捷键Ctrl+Z，使用该命令可以取消上次操作命令，使用该命令可以取消您最近的

一次操作。

：恢复命令，快捷键Ctrl+Y，使用该命令可以恢复上次操作命令，使用该命令可以恢复您最近的

一次操作。

：剪切命令，快捷键Ctrl+X，使用该命令可以删除您选择的图形对象，并把这些图形对象复制到

粘贴缓冲区中。

：复制命令，快捷键Ctrl+C，使用该命令可以复制您选择的图形对象到粘贴缓冲区中。

：粘贴命令，快捷键Ctrl+V，使用该命令可以把粘贴缓冲区中的图形对象复制到当前画面中。

：删除命令，快捷键Delete，使用该命令可以把您选择的图形对象从画面中删除。


标准状态栏

定义

标准状态栏如下图2-42所示：

图2-42 标准状态栏

如上图，工具条的各个命令与菜单中的内容是互相对应的，各个按钮的功能分别是：

标准状态栏：当选中一个控件的时候，显示控件的左，上坐标，

以及控件的宽度和高度


层次工具栏

定义

层次工具栏如下图2-41所示：

图2-41 层次工具栏

如上图，工具条的各个命令与菜单中的内容是互相对应的，各个按钮的功能分别是：

：移到最上层命令，使用该命令可以把你选择的图形对象置于画面的最上层。

：移到最下层命令，使用该命令可以把你选择的图形对象置于画面的最下层。

：移到上一层命令，使用该命令可以把你选择的图形对象上移一层。

：移到下一层命令，使用该命令可以把你选择的图形对象下移一层。


对齐工具栏

定义

对齐工具栏如下图2-45所示：

图2-45 对齐工具栏

如上图，工具条的各个命令与菜单中的内容是互相对应的，各个按钮的功能分别是：

：左对齐命令，使用该命令可以把您选择的多个图形对象的左边界在左边对齐。

：右对齐命令，使用该命令可以把您选择的多个图形对象的右边界在右边对齐。

：上对齐命令，使用该命令可以把您选择的多个图形对象的上边界在上边对齐。

：下对齐命令，使用该命令可以把您选择的多个图形对象的下边界在下边对齐。

：水平居中命令，使用该命令可以把您选择的多个图形进行水平方向的居中操作。

：垂直居中命令，使用该命令可以把您选择的多个图形进行垂直方向的居中操作。


控件工具栏

定义

工具栏如下图2-40所示：

图2-40 控件工具栏

如上图，工具条的各个命令与菜单中的内容是互相对应的，各个按钮的功能分别是：

：使用该命令可以建立一个可输入可显示静态文本。

：使用该命令可以新建一个开关，主要功能是负责位操作，字操纵，同时，开关还可以复用为指示灯，

监控单个和多个位地址的状态，多个位地址的组合状态，单个字地址的值状态。

：使用该命令可以新建一个数据输入显示器，它包含“数值输入显示器、ASCII码输入显示器”。

：使用该命令可以新建一个自定义表格，由用户通过脚本接口设置数据源，自定义按压事件，从而实现各种不同数据，都能以表格的形式显示。

：使用该命令可以新建一个柱状图，以柱状形式显示数据增减变化。

：XY趋势图以曲线显示形式，展示出数据的变化趋势。

：根据数据比例，以扇形方式显示大小。

：用于显示静态图片。


离线模拟栏

定义

工具栏如下图2-40所示：

图2-40 离线模拟栏

如上图，离线模拟菜单中的内容是互相对应的，按钮的功能是：

：运行，使用该命令可以在线模拟程序。

具体请点击 PC远程控制客户端


信息输出窗口

定义

信息输出窗口主要功能为输出当前所操作某项功能的信息，比如地址查找，输入地址，

点击确定后，则会在信息输出窗口中输出所写地址相同的控件名，如图所示：

信息输出窗口方位在工程软件的倒数第二层。


系统构成

定义

RemoteHMI是Samkoon触摸屏的画面组态编辑软件。RemoteHMI允许工程设计人员在PC机

上进行工程画面组态的编辑，然后通过USB把最终的组态画面和所需的通信驱动下载到触摸屏的

存储机构中运行，再通过执行机构和串口通信对PLC或其它的连接设备建立通信并进行相应的控

制和监视。下图2-42为RemoteHMI系统构成：

RemoteHMI

图2-42 RemoteHMI系统构成


基本操作

定义

本章介绍RemoteHMI组态软件操作的简单介绍RemoteHMI鼠标的用法，快捷键以及一些术语。

目录

l 鼠标操作和快捷键

l RemoteHMI的术语


RemoteHMI的术语

定义

下表2-3中罗列的是本书中在介绍工程画面组态时常用的一些名称。

工程 | 用户应用系统的简称。引入工程的概念，是使复杂的计算机专业技术更贴近于普通工程用户。在RemoteHMI组态环境中生成的文件称为工程文件，后缀为*.ak，可以存放在用户指定的地方。
对象 | 操作目标与操作环境的统称。如窗口、构件、数据、图形等皆称为对象。
选中对象 | 鼠标点击窗口或对象，使其处于可操作状态，称此操作为选中对象，被选中的对象（包括窗口），也叫当前对象。
组态 | 在窗口环境内，进行对象的定义、制作和编辑，并设定其状态特征（属性）参数，将此项工作称为组态。
属性 | 对象的名称、类型、状态、性能及用法等特征的统称。
菜单 | 是执行某种功能的命令集合。如系统菜单中的“文件”菜单命令，是用来处理与工程文件有关的执行命令。RemoteHMI的菜单都是下拉菜单形式，下拉菜单还可分成多级，每一级称为次级子菜单
命令按钮 | 具有某种命令操作的按钮，一部分按钮在工具栏中，一部分在菜单栏中
设置开状态 | 切换具有显示位状态的对象到位状态是“开”的状态
设置关状态 | 切换具有显示位状态的对象到位状态是“关”的状态
样式 | 对象从前景色到背景色的一种过渡效果
地址 | 与当前对象发生联系的存储器变量
连接设备 | 与当前工程发生通信的设备
控件 | 具有某类特殊功能的集合

表2-3 常用术语


鼠标操作和快捷键

定义

在组态画面编辑软件上使用鼠标制作组态画面时，鼠标如右图2-53所示：

图2-53 鼠标示意图

下面是对鼠标的几种常用的操作和这些操作在组态画面编辑软件上的用意：

◎左键单击

按左侧的键，然后松开在本书中称为[单击]，在选择菜单，选择对象，选择工具按钮，编辑画面组态

和确认设定时使用。

◎左键双击

连续快速的按左侧的健两次在本书中称为[双击]，对已经放置的部件进行属性设定,对画面、窗口属性，

触摸屏连接属性，触摸屏设置属性设定，创建历史数据收集，配方，报警等控件选项时，可以双击该部件，

则显示变更设定的对话框。

◎右键单击

按右侧的键，然后松开在本书中称为[右击]，对某部件进行右击操作可以打开右键下拉菜单，或者在空白

处右击操作显示右键菜单。还可以取消编辑画面状态，恢复鼠标形状。

◎拖曳

按住左键不放，移动鼠标在本书中称为[拖曳]，使用拖曳操作可以选定多个部件，移动部件，移动弹出的编辑窗口。

n 鼠标形状

在使用RemoteHMI组态画面编辑软件的时候，鼠标的形状会随组态使用者不同的操作会有不同的变化，

以区分不同操作类型，方便使用者操作。下表2-1为在画面编辑过程中不同的鼠标形状代表可以进行的操作：

11 | 可以选定对象，单击工具按钮
+ | 可以粘贴
20090522101626367 | 可以绘制图形
33 | 可以输入文本
20090522102318339 | 可以把对象在垂直面上放大
20090522102238822 | 可以把对象在水平面上放大
20090522103113602111111111 | 可以把对象在水平和垂直面上放大
 | 可以重新调整
88 | 可以把对象在水平和垂直面上放大
 | 可以把对象旋转

表2-1 鼠标形状及含义

n 快捷键

下表2-2中罗列的是一些常用的快捷键，方便工程设计人员快速的进行工程画面的组态：

CTRL+C | 复制
CTRL+V | 粘贴
CTRL+X | 剪切
CTRL+拖曳 | 复制选中对象，并移动
SHIFT+单击（CTRL + 单击） | 同时选中多个对象
←→↑↓ | 被选择的对象左右，上下移动
ESC | 取消命令操作
DEL | 删除
Tab | 控件之间相互切换

表2-2 快捷键


AK软件运行对计算机的需求

定义

内容：

l RemoteHMI 对运行计算机的软件需求

l RemoteHMI 对运行计算机的硬件要求


RemoteHMI对计算机的软件需求

定义

RemoteHMI组态软件可以在以下操作系统下运行：

· Microsoft Windows NT Server 4.0或更高版本；

· Microsoft Windows NT Workstation 4.0或更高版本；

· Microsoft Windows 98、Me、2000、XP、7或更高版本。

提示：不满足以上版本的操作系统，RemoteHMI将拒绝安装。

推荐系统：

推荐使用Windows XP SP3版本的操作系统。


RemoteHMI对计算机的硬件需求

定义

RemoteHMI系统要求在PC486以上的微型机或兼容机上运行，以Microsoft的Windows 2000、Windows XP和Windows 7系统。

最低配置

* CPU： 最低Pentium 3-800MHz计算机；

* 内存：当使用Windows 9X操作系统时内存应在128MB以上；

当选用Windows NT操作系统时，系统内存应在256MB以上；

当选用Windows 2000或XP操作系统时，系统内存应在256MB以上；

* 显卡：Windows系统兼容，含有1MB以上的显示内存，可工作于

1024*768分辨率，256色模式下；

* 硬盘：AKWorkshop组态软件占用的硬盘空间最少为4GB。

低于以上配置要求的硬件系统，将会影响系统功能的完全发挥。目前市面上

流行的各种品牌机和兼容机都能满足上述要求。

推荐配置

* CPU：使用相当于Intel公司的Pentium 800或以上级别的CPU；

* 内存：当使用Windows 9X操作系统时内存应在256MB以上；

当选用Windows NT操作系统时，系统内存应在512MB以上；

当选用Windows 2000或XP操作系统时，系统内存应512MB以上；

* 显卡：Windows系统兼容，含有1MB以上的显示内存，可工作于1024*768

分辨率，65535色模式下；

* 硬盘：硬盘空间4GB以上。


安装组态软件

定义

RemoteHMI是专为标准Microsoft Windows系统设计的32位应用软件。安装软件前，请确认

该计算机的软件和硬件是否符合安装的最低需求。

具体安装步骤如下：

· 执行文件setup_RemoteHMI.exe，启动安装程序后，弹出如下语言选择框，根据用户需要选择安

装英文或者简体中文组态软件，在此选择安装“简体中文”为例说明。选择“简体中文”点击“确

定”后，等几秒会弹出启动画面。

图2-3 选择语言

· 在弹出的对话框中选择下一步继续安装，选择取消可以退出安装程序，如下图2-4所示。安装前

请确认当前已经卸载了较早版本，否则会影响RemoteHMI的正常使用。

图2-4 安装欢迎界面

· 在许可证协议对话框中，请选择是否接受软件条款，然后点击下一步，如图2-5所示：

图2-5接受协议界面

· 在目标文件夹对话框中，选择安装文件夹，点击更改可以选择安装路径，然后点击下一步，

如图2-6所示：

图2-6 选择安装路径界面

· 如果用户之前已经安装了此软件，则会弹出“文件已存在”的消息提示框。如果想覆盖之

前安装的，点击“是”即可；否则点击“否”，则重新返回到图2-6界面，重新选择路径。

· 点击图2-6中的“是”后，出现选择安装在哪个文件夹下的选择界面，用户可以选择其他

文件夹，也可以默认文件夹。然后点击下一步，如图2-7所示：

图2-7 安装文件夹选择界面

· 是否选择创建桌面快捷方式界面，点击“下一步”，如图2-8所示：

图2-8是否选择创建桌面快捷方式界面

· 安装确认界面，该界面显示用户之前步骤中选择的安装路径、安装所在的文件夹以及是否

创建快捷方式这三项内容。点击“下一步”，如图2-9所示：

图2-9 安装确认界面

· 安装界面，点击“取消”则可以取消安装。如图2-10所示：

图2-10 安装界面

· 安装结束后，点击“完成”结束安装向导，如图2-20所示：

图2-20 安装完成界面

· 安装结束后，在桌面上会出现RemoteHMI的图标。如图2-21所示：

图2-22 快捷方式

· 在“开始”-----“所有程序”------------“RemoteHMI”中，选择“RemoteHMI”

也可以运行RemoteHMI组态软件。


RemoteHMI卸载组态软件

定义

卸载RemoteHMI组态软件请按下列步骤进行：

第一种方法：

第一步：选择Windows的“开始”—“所有程序”—“ RemoteHMI”，选择“卸载RemoteHMI”选项。

如图2-13所示：

图2-13 选择卸载任务

第二步：在弹出的对话框中左键单击“是”，等待Windows系统自动删除RemoteHMI软件，

删除完成后左键单击“完成”按钮就可以完成卸载任务了，如图2-14和图2-15所示：

图2-14 确定卸载

图2-15 卸载完成界面

第二种方法：

第一步：用户可以选择Windows的“开始”— “控制面板”，进入控制面板界面，选择

“程序/卸载程序”弹出对话框，如下图2-16所示：

图2-16添加/删除程序界面

第二步：在上图2-16中中间区域内选择RemoteHMI，鼠标右键单击“卸载(U)”按钮，按照第一种方法

的第二步和第三步，系统会自动删除RemoteHMI组态软件及其相应的组件。


PC远程控制客户端

定义

远程通信控制器具有透传数据的功能，能将HMI传递给PLC的数据转发给PLC，同时也能将PLC返回给HMI的数据转发给HMI。PC远程客户端就是建立在PC上的远程客户端。登录分为远程登录和局域网登录，登录的用户性质分为SK和AK登录，AK用户登录，没有“进入VNC”的功能，只有SK用户登录才有。

² 单击菜单栏下载“运行”或者离线模拟栏的“运行”，进入到登录页面

“远程登录”：

· 选择“远程登录”，“远程登录”是在有外网的情况下登录的。

图2-3 登录页面

· 填写用户名和密码，登录成功之后，可以查看所有在线或离线的设备。有上下翻页，设备搜索。

图2-4 设备列表

· 选中你想要查看的设备，点击下面的“进入VNC”或“进入组态”，或双击当前选择行可查看当前设备。

图2-5设备列表（1）

图2-6 设备列表（2）

· 选择“进入组态”

图2-7 组态界面

· 选择“进入VNC”

图2-8 VNC界面

“局域网登录”：

· 选择“局域网登录”，“局域网登录”只能查看当前IP地址的组态，填写IP地址和端口号。

图2-9 局域网登录

· 登录成功之后，只能查看当前的IP，有上下翻页，设备搜索。

图2-10 当前设备列表

· 选中设备，点击下面的 “进入组态”，或双击当前选择行可查看当前设备组态。

图2-10设备列表（1）

图2-10 设备列表（2）

· “进入组态”之前，须填写在RemoteHMI设置的进入画面连接密码

图2-11 进入画面密码界面

· 填写密码之后，点击“确定”就可以“进入组态”

图2-12 组态界面

· 选择“进入VNC”

图2-12 VNC界面

进入组态或VNC页面之后，即可远程对其操作。


创建工程基本步骤

定义

本章介绍创建新工程的基本步骤。

目录

l 用RemoteHMI创建远程客户端工程

l 用RemoteHMI创建远程控制器工程

l 下载组态程序


RemoteHMI创建远程客户端工程

定义

当工程设计人员需要新建一个工程时，将需要进行此操作。选择文件菜单中的新建命令或者选择工具栏菜单中的 [image] 新建工程按钮，RemoteHMI将会弹出“新建工程对话框”，选择存储工程的路径，并为该工程取一个名字。点击取消退出对话框。

1. RemoteHMI创建新工程对话框

l 工程名称：新建工程的工程名

l 保存路径：新建工程文件存放的路径

l 项目选择：远程客户端

图3-1 新建工程对话框

上图3-1即为新建工程对话框，工程设计人员选择好工程名称，工程保存路径，选择项目类型

即可单击下一步进行通讯口的设定。

提示：新建工程的名称不能含有以下字符：\ / : * ? " < > |以及windows中默认保留的字符串，比如Com1。

2. 通信连接

通信连接对话框用于设定触摸屏的通信口的通信参数，只有设定了正确的通信参数才能保证

触摸屏与PLC的正确通信，具体的通信参数由要连接的PLC的型号决定。

ü  连接接口：通信串口的名称。

ü  设备厂家：设备驱动的厂商。

ü  设备型号：该厂商的产品系列。

ü  站号：设置PLC编号，范围为0~255。

图3-2 通信连接对话框

上图3-2即为通信口设定对话框，工程设计人员可以在此对话框中根据自己所采用连接设备的

类型选择相应的设备服务。NET链接，就在“连接接口”中选择“NET”选项。

3. 画面属性

画面属性对话框用于设定画面的参数，设置画面名称，画面背景设置。

ü  画面名称：画面的名称。

ü  进入连接密码：设置验证成功，则可以进入组态界面，密码长度为6-16。

ü  画面背景设置：设置画面的分辨率以及背景。

ü  分辨率：设置画面的宽度与高度。

ü  默认：勾选默认，选择系统自带的背景色。如图3-2

ü  图片：勾选图片，选择图片的路径，把图片作为背景图片。如图3-2-1

图3-2 画面属性对话框

图3-2-1 画面属性对话框

上图3-2即为画面设定对话框，工程设计人员可以在此对话框中根据自己的需求类型选择

相应的设备服务。设置完毕之后点击完成，即可创建成功画面。

Birne ： AK-7，AK-10.2有两个COM口，

暂时只连接一台PLC时，由使用的COM口决定。AK-3.5A，

AK-4, AK-4.3, AK-4.3, AK-5只有一个COM口，只需设定COM1口。

Birne ：组态时也可以在工程管理器的连接中设定通讯属性，其他参数也在通讯属性里设定。


RemoteHMI创建远程控制器工程

定义

当工程设计人员需要新建一个工程时，将需要进行此操作。选择文件菜单中的新建命令或者选择工具栏菜单中的 [image] 新建工程按钮，RemoteHMI将会弹出“新建工程对话框”，选择存储工程的路径，并为该工程取一个名字。点击取消退出对话框。

1. RemoteHMI创建新工程对话框

l 工程名称：新建工程的工程名

l 保存路径：新建工程文件存放的路径

l 项目选择：远程控制器

图3-1 新建工程对话框

上图3-1即为新建工程对话框，工程设计人员选择好工程名称，工程保存路径，选择项目类型

即可单击下一步进行通讯口的设定。

提示：新建工程的名称不能含有以下字符：\ / : * ? " < > |以及windows中默认保留的字符串，比如Com1。

2. 通信连接

通信连接对话框用于设定触摸屏的通信口的通信参数，只有设定了正确的通信参数才能保证

触摸屏与PLC的正确通信，具体的通信参数由要连接的PLC的型号决定。

连接接口：

COM1为主串口，对应远程控制器中的COM1或者COM3；

COM2为从串口，对应远程控制器中的COM2或者COM4；

ü  连接接口：通信串口的名称。

ü  设备厂家：设备驱动的厂商。

ü  设备型号：该厂商的产品系列。

ü  站号：设置PLC编号，范围为0~255。

ü  IP设置：设置远程通信控制器的网络参数。

ü  组1配置：设置组1波特率、数据位、校验、停止位和超时时间配置。

ü  组2配置：设置组2波特率、数据位、校验、停止位和超时时间配置。

COM1的设置包括：

设备厂家、设备型号、站号。

COM1的波特率、数据位、校验、停止位和超时时间的设置在组1配置或者组2配置中进行，

默认组1配置。若要更改为组2配置，需要在组2配置前面打勾，并在弹出的窗口中点击是。

图3-2 通信连接对话框（1）

COM2的设置包括：

设备厂家、设备型号、站号。

COM2的波特率、数据位、校验、停止位和超时时间的设置在组1配置或者组2配置中进行，

与COM1选择的方式不同。若COM1为组1配置，COM2则为组2配置，若COM1为组2配置，COM1则为组1配置。

这些数据的设置要依据与远程通信控制器从串口相连设备的通信参数。

IP的设置（设置远程通信控制器的网络参数）：

设备连入网络方式为有线方式，需要设置：

IP地址、子网掩码和默认网关，这些参数根据设备所在网络进行设置；

设备连入网络方式为WiFi方式，需要设置：

勾选是否使用WiFi ，然后输入用户名和密码。如果WiFi无密码，则密码处不用输入任何值。

COM1的波特率、数据位、校验、停止位和超时时间的设置在组1配置或者组2配置中进行，

默认组1配置。若要更改为组2配置，需要在组2配置前面打勾，并在弹出的窗口中点击是。

图3-2 通信连接对话框（2）

上图3-2即为通信口设定对话框，工程设计人员可以在此对话框中根据自己所采用连接设备的

类型选择相应的设备服务。

3. 画面属性

画面属性对话框用于设定画面的参数，设置画面名称，画面背景设置。

ü  画面名称：画面的名称。

ü  进入连接密码：设置验证成功，则可以进入组态界面，密码长度为6-16。

ü  画面背景设置：设置画面的分辨率以及背景。

ü  分辨率：设置画面的宽度与高度。

ü  默认：勾选默认，选择系统自带的背景色。如图3-2

ü  图片：勾选图片，选择图片的路径，把图片作为背景图片。如图3-2-1

图3-3 画面属性对话框

图3-3-1 画面属性对话框

上图3-2即为画面设定对话框，工程设计人员可以在此对话框中根据自己的需求类型选择

相应的设备服务。设置完毕之后点击完成，即可创建成功画面。

Birne ： AK-7，AK-10.2有两个COM口，

暂时只连接一台PLC时，由使用的COM口决定。AK-3.5A，

AK-4, AK-4.3, AK-4.3, AK-5只有一个COM口，只需设定COM1口。

Birne ：组态时也可以在工程管理器的连接中设定通讯属性，其他参数也在通讯属性里设定。


画面——新增

操作

在工程管理器画面窗口选项卡中选择 [image] 右键点击“新建画面”就会弹出新建画面属性框，如下图：

属性图

选择“新建画面”，如下图：

属性概述

n 画面名称

必须给新建的画面设置名称

n 背景

为画面设置背景颜色或图片

l 默认

l 背景色：从颜色表中选择颜色,设置画面的背景色

l 图片：从本地文件中选择图片作为画面的背景


画面——属性

操作

选择一个已经建好的画面，右键点击“属性”，可以打开设置好的画面属性图，如下图：

属性图

选择“属性”，如下图：

打开属性图之后可以修改画面属性，画面属性详解请看画面新增


画面——删除

操作

选择一个已经建好的画面，右键点击删除，会弹出提示框，如下图：

属性图

选择“删除”，显示如下图：

选择“是” 可以删除选中的画面

如果是最后一个画面不能删除并且弹出以下提示


画面——复制

操作

选择一个已经建好的画面，右键点击“复制”，会弹出画面复制的框，如下图：

属性图

选择“复制”，如下图：

填写画面名称，点击确定，可以复制出一个新的画面


下载设置

操作

点击菜单栏中的 [image] 右键可以打开下载设置的属性设置框

属性概述

n 下载方式

² USB下载：通过连接USB数据线将数据下载到机器中

² 网络下载：通过网络设置IP来下载到指定IP的机器中（仅限于远程客户端）

² 下载到U盘：通过U盘来将数据下载到的机器中


组态指南

定义

本章详细介绍RemoteHMI的组态方法。

l 图形编辑命令

l RemoteHMI控件


基本控件

定义

本章主要介绍RemoteHMI基本控件的使用方法。

目录

l 开关

l 数据输入显示器

l 静态文本

l 自定义表格

l 柱状图

l XY曲线

l 饼图

l 图片


静态文本

操 作

1. 在控件栏中选择 [image] 这个图标，会出现静态文本的属性对话框

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置的

位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件。

3. 鼠标双击控件，则弹出属性设置界面，用户可以修改参数。

文本关键字：MAX、MIN和ABCD(大写)

因为自定义键盘上最大值、最小值和输出文本所用到的也是静态文本，为了区分自定义键盘上的

文本和静态文本控件，若在文本框中输入的字符含有大写的MAX、MIN和ABCD,则代表自定义

键盘上的文本，选择了多语言时只选择第一种语言，不影响控件的基本功能。

目 录

l 基本设置


静态文本——外观设置

定义

设置静态文本的字体属性

属性图

属性概述

n 文本属性

对显示的文本属性进行设置

l 对齐：选择字体的对其位置(居中、左对齐、右对齐)

l 大小：显示字体大小5~256

l 颜色：给文字设置颜色

l 文本输入：输入要显示的字符

n 填充

设置文本背景边框的填充样式

l 透明度：设置文本背景的透明度

l 背景色：设置文本背景的背景色

当选择样式为纯色和透明的时候，前景色不显示


开关

操 作

1. 在控件栏中选择 [image] 这个图标，会出现开关的属性对话框

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置的

位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件。

3. 鼠标双击控件，则弹出属性设置界面，用户可以修改参数。

定义

开关的主要功能是负责位操作，字操纵，同时，开关还可以复用为指示灯，

监控单个和多个位地址的状态，多个位地址的组合状态，单个字地址的值状态。

目 录

l 功能设置

l 指示灯设置

l 外观设置


开关功能

定义

开关功能包含位开关、字开关、画面开关、功能开关和指示灯。

目录

l 位开关

l 字开关

l 画面开关

l 功能开关

l 指示灯


功能开关

定义

功能开关按钮在整个触摸屏中是很重要的控件，通过功能按钮可以很方便快捷的达到各种功能要求。

属性图

属性概述

n 功能设定

l 选择功能：分为地图，下载组态，下载配方，下载PLC程序，下载客户端程序，上载配方，上载报警数据，上载历史数据，上载组态。

u 产品分布图：用地图形式，显示各个地区产品分布情况。在某个市的所有产 品设备分布中，求得这些设备的所在的经度纬度的平均分布点后标注，标注上的数值即是改城市的产品总数量。

u 下载组态：从AK点击“下载工程”，选择“下载到U盘”，选择下载的路径，然后点击“下载”，会生成一个samkoonhmi.akz文件，然后再把akz文件也就是组态下载到屏里。

u 下载配方：从AK下载配方到屏里。

u 下载PLC程序：在组态中添加功能按钮，设置其功能为下载PLC程序；打开VSPD软件，在电脑中增加一对虚拟串口，添加的是虚拟COM4和COM5；登录进入远程客户端，在组态中点击下载PLC程序的按钮，会弹出对话框，设置波特率等参数，参数设置同PLC与电脑编程软件直连的参数。在电脑端打开PLC编程软件，设置传输设置，串口采用另一个虚拟串口COM5。测试通信是否成功，成功后可以进行PLC程序的下载。

u 下载客户端程序：在RemoteHMI软件中，从菜单栏中点击“下载”à“生成app.akz”,会弹出一个对话框，选择打包的路径，然后点击“打包”，就会生成一个App.akz文件。此时再点击“下载工程”，就可以把当前程序下载到PC端或手机里。

u 上载配方：从屏里上载配方到PC。

u 上载报警数据：从屏里上载报警数据到PC。

u 上载历史数据：从屏里上载历史数据到PC。

u 上载组态：从屏里上载组态到PC。

选择类型：根据选择的功能设置选择类型。


画面开关

定义

画面按钮主要用于画面的切换、改变用户等级和弹出窗口等操作。触控设置好后的画面按钮可以使画面/窗口跳转到所设置的画面/窗口上去操作，在跳转的过程中还可以选择是否改变用户等级。

属性图

属性概述

n 操作设定

l 操作类型：分跳转到下一个画面、跳转到指定画面、打开窗口、关闭窗口。

u 跳转到下一个画面：点击画面按钮，则可跳转至下一个画面。比如有3个画面，画面按钮在画面1，点击则跳转至画面2.

u 跳转到指定画面： 设置好画面名称，点击画面开关则可跳转到指定画面。比如有3个画面，设置画面名称为“画面3”，画面按钮在画面1，点击则跳转至画面3.

u 返回上一个画面：点击画面开关按钮则返回上一个画面


位开关

定义

位按钮可以用来操作和显示与触摸屏所连接的设备的位地址 ON/OFF状态，或者1/0状态。位按钮是最基本的，也是最常用的控件。

属性图

属性概述

n 地址设定

l 写入地址：使用位地址来控制开关与其他控件的位地址。

n 操作设定

l 操作类型：分为置位、复位、点动、交替。

u 置位：选择“置位”功能，下载到HMI上后，单击该位按钮即可把写入地址的值置成1，即把连接设备的该写入地址置成ON状态，并显示1/ON状态。

u 复位：选择“复位”功能，下载到HMI上后，单击该位按钮即可把写入地址的值置成0，即把连接设备的该写入地址置成OFF状态，并显示0/OFF状态。

u 点动：选择“点动”功能，包含了“按下为1”和“按下为0”这两个功能。当选择的是“按下为1”功能后，下载到HMI上后，当对位按钮进行触控操作时，按住位按钮可把连接设备所写入的地址的值置成1/ON，显示1/ON状态；松开触碰时把所写入地址的值置成0/OFF，显示0/OFF状态；当选择的是“按下为0”功能后，下载到HMI上后，当对位按钮进行触控操作时，按住位按钮可把连接设备所写入的地址的值置成0/OFF，显示0/OFF状态；松开触碰时把所写入地址的值置成1/ON，显示1/ON状态。

u 交替：选择“交替”功能，下载到HMI上后，若当前位按钮的状态为0/OFF时，当对位按钮进行触控操作，触碰该位按钮，把写入地址的值置成1/ON，显示1/ON状态；若当前位按钮的状态为1/ON时，当对位按钮进行触控操作，触碰该位按钮，把写入地址的值置成0/OFF，显示0/OFF状态；状态随触碰依次交替变化。

l 执行方式：当操作类型为“点动”时，执行方式可选。分（按下为0/1）。具体介绍请看点动操作类型的介绍。

l 读取：当勾选此选项时，会出现如下图所示：

如果再勾选“读取地址与写入地址相同”，则读取地址输入框变为灰色，不可输入，如未勾选则读取地址是自定义的。

l 实时读取（远程控制器）：勾选了实时读取的地址，不管HMI是否与该地址进行通信，都会对该地址进行读取。此功能只有是远程控制器的项目才有，如下图所示：


指示灯

定义

指示灯可以用来监视的所连接的设备的位触点ON/OFF状态，并可以在触摸屏上以相应的ON/OFF 状态来显示位触点的状态

属性图

点击指示灯按钮会直接跳转至下图：指示灯设置

指示灯只有监视功能。


字开关

定义

字按钮可以对连接设备的数据寄存器进行输入定值，输入数值，递加，递减，输入密码，对寄存器的数值加减运算等操作。

属性图

属性概述

n 地址设定

l 字地址：设置子开关的字地址。

l 数据类型：选择字地址的数据类型

数据类型

位 长 | 类 型 | 范 围
16位 | 整数 | -32768 ~ 32767
 | 正整数 | 0 ~65535
 | BCD码 | 0 ~ 9999
32位 | 整数 | -2147483648~2147483647
 | 正整数 | 0~4294967295
 | BCD码 | 0~99999999
 | 浮点数 | -9.9e16 ~ 9.9e16

n 操作设置

l 操作类型：写入数据、数值加、数值减、连续加、连续减。

u 写入数据：设置好字地址和常数后，点击字开关，就会输出常数。比如：设置好字开关的写入地址为LW0，常数为10；再设置数值显示器的地址为LW0，下载到屏里，点击字开关，数值显示器显示的值就为10。

u 数值加：设置好数据类别，写入地址，常数以及最大值后，每次触控该“字按钮”控件，写入地址所对应的寄存器的值就会在原来的基础之上加上所设置的常数值。因每次触控该按钮，写入地址的值都会加上一个常数，但写入地址的值不能超过你设置的最大值。例如：写入地址是LW1，常数设置为5，最大值为65535。运行后每次单击该“字按钮”控件，LW1的值都会在原来的基础上加上5，但LW1的值最大不能超过65535。

u 数值减：设置好数据类别，写入地址，常数以及最大值后，每次触控该“字按钮”控件，写入地址所对应的寄存器的值就会在原来的基础之上减去所设置的常数值。因每次触控该按钮，写入地址的值都会减去一个常数，但写入地址的值不能低于你设置的最小值。例如：写入地址是LW1，常数设置为5，最小值为0。运行后每次单击该“字按钮”控件，LW1的值都会在原来的基础上减去5，但LW1的值最小不能小于0。

u 连续加：当“延时参数”为0时，该功能和“加”功能相同；如“延时参数”不为0时，在模拟或者屏中，点击该控件，经过“延时参数”设置的时间后，写入地址的值会不停的加上常数值，并写入到写入寄存器中。

u 连续减：当“延时参数”为0时，该功能和“减”功能相同；如“延时参数”不为0时，在模拟或者屏中，点击该控件，经过“延时参数”设置的时间后，写入地址的值会不停的减去常数值，并写入到写入寄存器中。

l 常数：可以选择不同的数据类别，软件为工程设计提供多种数据类别：16/32位正整数，16/32位整数，16/32位BCD正整数和32位浮点数。设常数就是给写入地址写入您所设置的常数值。例如：写入地址为LW1，常数设置为10，则每次触控该按钮时，无论此时LW1的值为多少，LW1的值都被置成常数值10。


开关——外观设置

定义

设置开关文本的字体样式和图片。

属性图

属性概述

n 文本属性

l 状态数：选择当前的状态。

l 对齐：选择字体的对其位置(居中、左对齐、右对齐)。

l 大小：显示字体大小1~128。

l 文本色：给文字设置颜色

l 文本输入：输入要显示的字符

l 从0状态复制：例如，0状态的时，文本值为“TEXT111”，改变状态值后，点击“从0状态复制”按钮，文本框中的值也变成了“TEXT111”。

n 外形属性

l 从0状态复制：可参考文本属性的“从0状态复制”。

l 选择图库：在软件的图库中选择设定的图案外形。

l 选择外部图片：可在本地电脑中选择图片做为开关的外形图案

l 不使用图片：使用系统单纯的颜色做为开关的背景色


开关——指示灯设置

定义

位指示灯可以用来监视的所连接的设备的位触点ON/OFF状态，并可以在触摸屏上以相应的ON/OFF 状态来显示位触点的状态

属性图

属性概述

n 指示灯功能

l 指示灯功能：分双态监视和多态监视。

当用户没有选择监视的时候，位按钮的开关状态不会随触碰控件而改变其值。

l 双态监视：分地址类型、监视地址和是否与操作地址相同等属性。以两种方式进行监视。

u 地址类型：选择是位地址还是字地址。

u 字的位：如果是字地址，即可选择。

l 多态监视：分数据类型、状态数、状态条件切换等属性。可以以多种形式进行监视。

u 数据类型：包含16/32位整数、16/32位正整数、32位浮点数，写入地址和监视（读取）地址的数据类型。

u 读取地址：根据地址类型，输入相应的地址。详细请看双态监视的监视地址。

u 状态数：用户可根据个人需要设置总状态的数目，最多可设置256个状态。即0-255状态。

u 状态条件切换：分按数值切换、按寄存器的位切换和自定义状态值切换。

按寄存器的位切换：地址指向的值按二进制排列，为1的就显示，为0的就不显示，例如：监视地址为LW0 地址值为8，转成二进制则1000，那么第4位的值为1，则第4个状态显示

l 读取地址：输入要读取的地址。

l 实时读取（远程控制器）：勾选了实时读取的地址，不管HMI是否与该地址进行通信，都会对该地址进行读取。该功能只有远程控制器的项目才有，如下图所示：

当用户选择了此选项的时候，在“自定义状态值”之后会出现一个“定义状态值…”的按钮，如图：


数据输入显示器

定义

数据输入显示器包含“数值输入显示器、ASCII码输入显示器”。

目录

l 数值输入显示器

l ASCII码输入显示器


ASCII输入显示器

操 作

1. 在控件栏中选择 [image] 这个图标，会出现数据显示器的属性设置框我们选择第二个图标，

ASCII输入/显示就会出现有关ASCII输入显示器的属性设置内容

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置

的位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件。

3. 鼠标双击控件，则弹出属性设置界面，用户可以修改参数。

目 录

l 基本

l 显示

l 外观设置


ASCII输入显示器——基本

定义

显示保存在控制器/PLC指定地址中的数据 或 向控制器/PLC指定地址中输入数据

属性图

属性概述

n 读取地址

输入要读取的地址

n 允许写入

勾选这个选项后，如果再勾选“与读取地址相同”，写入地址不可用，则反之。

n 编码格式

设置ascii码的显示的编码格式

l Unicode编码：选择该选项用户可以正常显示中文，输入的字符均采用unicode编码进行显示


ASCII显示器——外观设置

定义

设置ASCII显示器的外观，包括外形和字体颜色

属性图

属性概述

n 图片

可以从图库中选择合适的图片作为数值显示器的外形

n 文本颜色

设置显示器中文本的显示颜色，可以从颜色表中选择。

n 文本背景颜色

设置ascii输入显示器的背景颜色，当选择了图片作为外形时，文本背景颜色变为透明。

n 透明度

控件显示背景的透明度，范围是0 到 255.

不能设置的低限值，高限值，低位背景色，高位背景色只针对数值显示器有效，ASC码显示器没有低位和高位


ASCII输入显示器——显示

定义

设置ASCII输入显示器的字体和属性

属性图

属性概述

n 字体

对显示的数值字体和大小进行设置

l 大小：对显示数值字体大小的设置，范围是5 ~ 256

n 显示字符数

ASCII码输入显示器显示的字符的数量

n 样式

l 左对齐：显示的数值位于显示区域的左侧

l 居中： 显示的数值位于显示区域的中间

l 右对齐：显示的数值位于显示区域的右侧


数值输入显示器

操 作

1. 在控件栏中选择 [image] 这个图标，会出现数据显示器的属性设置框，我们选择第一个图标，

数值输入/显示，就会出现有关数值输入显示器的属性设置内容

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置的

位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件。

3. 鼠标双击控件，则弹出属性设置界面，用户可以修改参数。

目 录

l 基本

l 显示

l 外观设置

l 缩放设置


数值输入显示器——基本

定义

显示保存在控制器/PLC指定地址中的数据 或 向控制器/PLC指定地址中输入数据

属性图

属性概述

n 数据类型

显示的数据类型

位 长 | 类 型 |  | 范 围
16位 | 整数 |  | -32768 ~ 32767
 | 正整数 |  | 0 ~65535
 | BCD码 |  | 0 ~ 9999
 | 8进制数 |  | 0 ~ 177777
 | 16进制数 |  | 0 ~ FFFF
32位 | 整数 |  | -2147483648~2147483647
 | 正整数 |  | 0~4294967295
 | BCD码 |  | 0~99999999
 | 浮点数 |  | -2147483648~2147483647
 | 8进制数 |  | 0 ~ 37777777777
 | 16进制数 |  | 0~FFFFFFFF
 |  | 当数据类型为浮点数时，可以勾选四舍五入，例如显示一位小数，则在第二位小数上做四舍五入操作。

n 读取地址

输入要读取的地址

n 实时读取（远程控制器）

勾选了实时读取的地址，不管HMI是否与该地址进行通信，都会对该地址进行读取。该功能只有远程控制器的项目才有，如图所示：

n 允许写入

写入地址设置，可以和监控地址一样。勾选这个选项后，以下的功能可用，如下图所示：

如果勾选“与读取地址相同”，“写入地址”不可输入，则反之。

n 写入地址

写入地址设置，可以和监控地址一样。

n 数值输入范围

范围类型：常量（默认数值或者由用户设置）、地址（由地址控制数值）

最大/小值：当范围类型为常量时，由用户设置输入范围，数值长度由显示总位数和数据类型决定，当显示总位数长度的最大值超过数据类型的最大值时，则采用数据类型的最大值，否则可采用该长度的最大值；当为地址时，可输入的范围由地址控制。

n 缩放设置

执行缩放后，将根据源范围和显示范围自动转换[监控字地址]的数据。结果显示转换后的数值。

详细说明

n 缩放设置（将数值显示为一个相对值）

执行缩放后，将根据源范围和显示范围自动转换【监控字地址】的数据，结果显示为相对值。

例如：

l 显示缩放

结果= ((显示范围最大值 - 显示范围最小值/ (源范围最大值 - 源范围最小值))

* (地址值 - 源范围最小值) + 显示最小值

l 写入缩放

结果= ((源范围最大值 - 源范围最小值) / (显示最大值 - 显示最小值))

* (输入值 - 显示范围最小值) + 源范围最小值

源范围

l 常量：指定一个设定的常量作为最大和最小值

l 地址：指定保存最大值最小值的地址

显示范围

l 常量：指定一个设定的常量作为最大和最小值

l 地址：指定保存最大值最小值的地址


数值输入显示器——缩放

定义

设置缩放设置的源范围和显示范围

属性图

当勾选缩放设置，会出现“缩放设置”的选项卡，如下图所示：

属性概述

n 源范围

l 最小值：设置最小缩放为-32768，默认为-32768

l 最大值：设置最大缩放为32767，默认为32767

n 显示范围

l 最小值：设置最小缩放为-32768，默认为-32768

l 最大值：设置最大缩放为32767，默认为32767


数值输入显示器——外观设置

定义

设置数值显示器的外观，包括外形和字体颜色

属性图

属性概述

n 图片

可以从图库中选择合适的图片作为数值显示器的外形

n 数值颜色

设置显示器中数值的显示颜色，可以从颜色表中选择。

n 数值背景颜色

设置数值显示器的背景颜色，当选择了图片作为外形时，数值背景颜色变为透明。

n 低限值

设置数值显示器的最低限制，小于时数值背景颜色变为低位背景色

n 高限值

设置数值显示器的最高限制，大于时数值背景颜色变为高位背景色

n 低位背景颜色

数值低于低限值的时候显示低位背景色

n 高位背景颜色

数值高于高限值的时候显示高位背景色

n 透明度

控件显示背景的透明度，范围是0 到255


数值输入显示器——显示

定义

设置数值输入显示的字体和属性

属性图

属性概述

n 字体

对显示的数值字体和大小进行设置

l 大小：对显示数值字体大小的设置，范围是5 ~ 256

n 显示位数

l 总显示位数：设置数值最多能显示几位，显示位数包括小数点后面的数字。但是，显示位数不包括小数点。最大最小值受数据类型控制。

l 小数位数：设置数值显示的小数位数，当指定选择常量时，小数位数值自己控制，当指定选择地址时，小数位数值受地址控制。小数位数的最大最小值受数据类型的控制。

l 隐藏输入值（显示*号）：不显示你输入的值，就像密码一样

n 样式

l 左对齐：显示的数值位于显示区域的左侧

l 居中： 显示的数值位于显示区域的中间

l 右对齐：显示的数值位于显示区域的右侧

详细概述

n 小数位数

小数位数长度表

位 长 | 类 型 | 总显示位数 | 小数位数
16位 | 整数 | 1 ~ 5 | 0 ~ 4
 | 正整数 | 1 ~ 5 | 0 ~ 4
 | BCD码 | 1 ~ 4 | 0 ~ 3
 | 8进制数 |  |
 | 16进制数 |  |
32位 | 整数 | 1 ~ 10 | 0 ~ 9
 | 正整数 | 1 ~ 10 | 0 ~ 9
 | BCD码 | 1 ~ 8 | 0 ~ 7
 | 浮点数 | 1 ~ 7 | 0 ~ 6
 | 8进制数 |  |
 | 16进制数 |  |


自定义表格

操 作

1. 在控件栏中选择自定义表格 [image] 这个图标，会出现“自定义表格”的属性对话框

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置的

位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件。

3. 鼠标双击控件，则弹出属性设置界面，用户可以修改参数。

目 录

l 外观设置

l 保存输出


自定义表格——保存输出

定义

自定义表格保存输出的数据源为报警。

属性图

属性概述

n 报警信息格式

l 报警时间：格式为 h:m:s，即为 时/分/秒

l 报警日期：格式为 Y/M/D，即为 年/月/日

l 报警内容：报警所显示的提示内容

表格可触控


自定义表格——外观设置

定义

自定义表格：由用户设置数据源，实现各种不同数据，都能以表格的形式显示。

属性图

属性概述

n 表格外观属性

对显示的表格属性进行设置

l 背景色：鼠标点击背景色按钮设置表格的背景颜色

l 描边：选择是否需要设置表格外边框颜色

l 边框色：点击边框色按钮设置表格边框颜色

l 透明度：设置表格背景透明度，范围为0~255

l 横向个数：设定表格横向线个数，范围为1~30

l 纵向个数：设定表格纵向线个数，固定值为3

l 翻页控制：设定表格是否可以翻页（包含动态控制状态）

l 报警：设置表格的数据源为报警

l 水平：选择表格是否需要水平线

l 垂直：选择表格是否需要垂直线

l 线条类型：设定表格内边线的线样式，有6种可供选择

l 线条颜色：点击线条颜色按钮设置表格内线条颜色


自定义表格——翻页

定义

自定义表格：由用户设置数据源，实现各种不同数据，都能以表格的形式显示。

属性图

属性概述

n 翻页控制地址

对控制翻页属性进行设置

l 定义：可选，长度为4，数据类型16位正整数

l 第一位：控制上下翻页，即控制地址为LW10

l 第二位：控制左右翻页，即控制地址为LW11

l 第三位：当前页码，即控制地址为LW12

l 第四位：总页数，即控制地址为LW13

n 对外接口

对每个接口属性进行设置

l 数据源设置接口：FBase.setTableData(int id,ArrayList<String[]> data);

Ø 参数id表示表的标识符，用于区分不同的表，data表示要设置的数据源，如下例子：

ArrayList<String[]> data =new ArrayList<String[]>();

String [] r1=new String[]{"1","2","3","4"};

String [] r2=new String[]{"11","22","33","44"};

data.add(r1);

data.add(r2);

FBase.setTableData(26,data);

l 设置行数据接口：FBase.setTableRowData(int id,int row,String[] data);

Ø 参数id表示表的标识符，用于区分不同的表，row表示要插入的行数，data表示要设置行的数据源，如下例子：

String[] data ={"row1","row2","row3"};

FBase.setTableRowData(26,1,data);

l 获取行数据接口：FBase.getTableRowData(int id,int row);

Ø 参数id表示表的标识符，用于区分不同的表，row表示要获取数据的行数，如下例子：

FBase.getTableRowData(26,1);

l 获取单元格数据接口：FBase.getTableCell(int id,int row,int rank);

Ø 参数id表示表的标识符，用于区分不同的表，row表示要获取数据的行数，rank表示要获取数据的列数，如下例子：

FBase.getTableCell(26,1,1);

l 删除行数据接口：FBase.deleteTableRowData(int id,int row);

Ø 参数id表示表的标识符，用于区分不同的表，row表示要删除数据的行数，如下例子：

FBase.deleteTableRowData(26,1);


柱状图

操 作

1. 在控件栏中选择 [image] 这个图标，会出现“柱状图”的属性对话框

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置的

位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件。

3. 鼠标左键双击控件，则弹出属性设置界面，用户可以修改参数。

目 录

l 基本设置

l 显示设置


柱状图——基本设置

定义

柱状图是将数据的实习变化以柱状增减的形式表现出来，使数值的实习变化更加明了。显示保存在控制器/PLC指定地址中的数据 或 向控制器/PLC指定地址中输入数据。

属性图

图表属性概述

n 监控字地址

柱状图能显示的数据寄存器地址，即读取地址。

n 数据类型

从[16位整数]、[16位正整数]、[32位整数]、[32位正整数]或[32位浮点]中选择柱状图显示数据类型。

n 源范围

l 指定源范围：分常量和地址。

l 最大/小值： 当“指定源范围”是常量时，由用户自己设置范围的最大/小值；当“指定源范围”是地址时，则最大/小值的是动态变化的，由用户所选择的地址来定，地址的数据类型和用户选择的“数据类别”相同。

n 显示范围

l 最小值： 即监视（读取）地址的值所能显示的最小值。

l 最大值：即监视（读取）地址的值所能显示的最大值。

n 图表形状

l 显示方向：分向上、向下、向左、向右。

详细如下：

u 柱状图

显示方向：

往上：当监视地址的数值增加时，柱状面由下向上滚动；

往下：当监视地址的数值增加时，柱状面由上向下滚动；

往左：当监视地址的数值增加时，柱状面由右向左滚动；

往右：当监视地址的数值增加时，柱状面由左向右滚动；


柱状图——显示设置

定义

柱状图显示设置，可以设置柱状图显示的颜色、图案、图案色，背景的颜色、图案、图

案色，以及是否显示主次刻度和显示数量。

属性图

属性概述

n 属性设置

l 显示颜色：设置显示的颜色

l 图案：设置显示的图案。

l 图案色： 设置显示的图案色。

l 背景图案： 设置背景的图案

l 背景图案色： 设置背景的图案色。

l 背景色： 设置背景的颜色。

l 标尺颜色： 设置刻度标尺的颜色。

n 刻度

l 显示主刻度：选择是否显示主刻度，设置范围为2~20。

l 主刻度分割数：设置报警上限值，超出此值则报警。

l 显示次刻度：选择是否显示次刻度。

l 次刻度分割数：设置次刻度分割的数量，设置范围为1~5。


XY 曲线

操 作

1. 在控件栏中点击 [image] 这个图标，则弹出XY曲线属性设置框

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置的

位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件。

3. 鼠标左键双击控件，则弹出属性设置界面，用户可以修改参数。

目 录

l 通道设置

l 显示设置


XY曲线——通道设置

定义

X-Y曲线可以绘制多个数据的参考曲线。

属性图

属性概述

n 曲线属性设置

l 通道数：范围[1-16], 最小1个通道，最大16个通道

l 采用点数: 范围[1-100]，采用点数表示采集多少个地址值，例如：10 表示 首地址之后，连续10个地址。

l 数据类型: 采集地址和显示范围地址的数据类型

l 触发地址: 控制采集地址并刷新界面，当地址值位true，表示一直采集，false则停止采集，自动复位：表示采集一次之后，自动复位

n 显示范围

设置曲线坐标最大最小值

l 最大值：曲线坐标最大的值, 可选[ 固定值,地址 ]

l 最小值：曲线坐标最小的值,可选[ 固定值,地址 ]

n 缩放

启动缩放可以对地址进行放大和缩小

l 最大值：曲线坐标最大的值, 可选[ 固定值,地址 ]

l 最小值：曲线坐标最小的值,可选[ 固定值,地址 ]

n 曲线基本属性

设置曲线的基本属性

l 所有曲线属性相同：以下属性一设置，所有曲线都用这种属性

l 当前通道号：当前曲线的属性，勾选所有属性相同，则其他曲线属性跟第一个相同

l 线型：线的样式，有如下

l 线宽：每根曲线宽度的设置

l 显示颜色：每根曲线颜色的设置

l 显示条件：显示曲线的条件，有如下

l 显示ON/OFF地址：显示条件的监控地址，在保持显示的时候会隐藏


XY曲线——显示设置

定义

X-Y曲线可以绘制多个数据的参考曲线。显示设置可以设置x-y曲线的文本、标尺刻度、曲线的颜色设置以及网格。

属性图

属性概述

n 文本

设置刻度值文本颜色和大小，字体大小设置范围为1~24。

n 标尺刻度

设置动态矩形宽度，高度以及固定点的设置

l 垂直主标尺：Y轴总共要画出多少个主刻度，设置范围为1~20。

l 水平主标尺：X轴总共要画出多少个主刻度，设置范围为1~20。

l 垂直次标尺：Y轴每个主刻度中分多少个等份，设置范围为2~10，不勾选就不要次刻度。

l 水平次标尺：X轴每个主刻度中分多少个等份，设置范围为2~10，不勾选就不要次刻度。

l 显示垂直主标尺刻度：勾选是否显示垂直刻度。

l 显示水平主标尺刻度：勾选是否显示水平刻度。

n 颜色设置

设置曲线显示的颜色

l 边框色：曲线边框的颜色

l 标尺色：曲线主刻度的颜色

l 图表区色：曲线图标区的颜色

n 网格

设置曲线网格的颜色，不够选网格就不会再图上画网格

l 垂直网格颜色：垂直刻度引申出来的线的颜色

l 水平网格颜色：水平刻度引申出来的线的颜色


饼图

操 作

1. 在控件栏中选择 [image] 这个图标，会出现“饼图”的属性对话框

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置的

位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件。

3. 鼠标左键双击控件，则弹出属性设置界面，用户可以修改参数。

目 录

l 基本设置


饼图——基本设置

定义

饼图是将一组数据比例关系以扇形的形式表现出来的控件，显示保存在控制器/PLC指定地址中的数据 或 向控制器/PLC指定地址中输入数据。

属性图

属性概述

n 数据类型

从[16位整数]、[16位正整数]、[32位整数]、[32位正整数]或[32位浮点]中选择柱状图显示数据类型。

n 总数

设置显示比例的总数，设置范围为2~12。

n 起始角度

设置显示比例的起始角度，设置范围为0~360，单位为度（°）。

n 透明度

设置饼图的透明度，设置范围为0~255。

n 显示

l 显示描述：勾选是否显示描述的文本。

l 显示比例： 勾选是否显示百分比。

n 填写地址和描述文本

根据填写的总数，会自动生成相应数量的地址和文本，双击进相应文本框填写即可。如图：


图片

定义

图片显示器，用于显示静态图片。

属性

属性概述

n 删除图片

点击“删除图片”，可以删除已经选定好的图片。

n 选择图库

点击“选择图库”，可以看到系统存在的图片，在“扩展图库”目录右键选择“新建”，可以建立自己自定义的图片目录

在新建的图片目录右键，可以选择“导入”或者选择“删除”图片，选择导入即可导入图片

导入图片后，点击图片后选择确定或者双击图片就可以选择该图片。

n 选择外部图片

点击“选择外部图片”，选择你要选择该图片的目录，点击“打开”即可。


图形编辑命令

定义

本章详细介绍RemoteHMI的图形编辑命令。

目录

l 层次

l 对齐


层次

定义

层次命令是一个组命令。AKWorkshop组态画面编辑软件的层次命令用于调整画面中相交的图形对象

的前后显示顺序。AKWorkshop中每一个图形对象都有一个层次，上层的图形对象总是显示在底层图形

对象的上面，因此可以用层次命令来调整图形对象的层次级别。后创建的图形对象层次默认比前创造的

图形对象的层次要高。AKWorkshop的层次命令一共有4个，分别是对象前移，对象后移，对象前移一层，

对象后移一层。要执行这些命令，先在当前画面上选择一个或者多个图形对象，然后选择编辑菜单中层次

对应的命令或者工具栏按钮中对应的层次命令按钮。

Ø 对象前移

用于将被选择的图形对象移到画面中所有图形对象的最前面，这样其他图形对象画面与该图形对象

相交的画面将会被该图形对象覆盖，对象前移-前后对照如图4-8所示：

首先需选择多个图形中的一个对象，然后选择编辑菜单中的移到最上层命令或者是工具栏按钮中的组合

命令按钮 13 ，或者右键调出右键菜单，选择“层次”项中的“移到最上层命令”命令，组合前后对照

如图4-8所示：

图4-8 对象前移前后对照

Ø 对象后移

用于将被选择的图形对象移到所有图形对象的的后面，这样该图形对象与其他图形对象相交的画面将不可视，

对象后移前后对照如图4-9所示：

首先需选择多个图形中的一个对象，然后选择编辑菜单中的移到最下层命令或者是工具栏按钮中的组合命令

按钮 14 ，或者右键调出右键菜单，选择“层次”项中的“移到最下层命令”命令，组合前后对照如图4-9所示：

图4-9 对象后移前后对照

Ø 对象前移一层

用于将被选择的图形对象移到与之相交的图形对象的前面一层，这样其他图形对象与该图形对象相交的画面将不可视，

对象前移一层前后对照如图4-10所示：

首先需选择多个图形中的一个对象，然后选择编辑菜单中的移到上一层命令或者是工具栏按钮中的组合命令按钮 15 ，

或者右键调出右键菜单，选择“层次”项中的“移到上一层命令”命令，组合前后对照如图4-10所示：

图4-10 前移一层前后对照

Ø 对象后移一层

用于将被选择的图形对象移到与之相交的图形对象的后面一层，这样该图形对象与其他图形对象相交的画面将不可视，

对象后移一层前后对照如图4-11所示：

首先需选择多个图形中的一个对象，然后选择编辑菜单中的移到下一层命令或者是工具栏按钮中的组合命令按钮 16 ，

或者右键调出右键菜单，选择“层次”项中的“移到下一层命令”命令，组合前后对照如图4-11所示：

图4-11 后移一层前后对照


对齐

定义

对齐也是一个组命令。RemoteHMI组态画面编辑软件允许工程设计人员对多个图形对象进行对齐

的操作，对齐只对在选择了多个图形对象的情况下才能操作。用户可以按住shift不放，多个选择所要

对齐的图形对象，也可以按住鼠标左键用拖曳的方法圈定所要对齐的图形对象。对齐可以使组态画面变

得更加的美观。对齐操作包括大量的编辑命令，有左对齐，右对齐,上对齐，下对齐，垂直居中,水平居

中。

Ø 左对齐

左对齐允许工程设计人员在选择多个图形对象后（必须2个以上的图形对象），点击编辑菜单中对齐项中的

“左对齐”命令或者点击工具按钮中的左对齐按钮 [image] ，或者调出右键菜单，然后点击右键菜单中对齐项中的

“左对齐”命令。这些图形对象会以最左边为基准，往左移动使各个图形对象的左边沿在同一垂直线上。左对齐

前后对照如图4-19所示：

图4-19 左对齐前后对照

Ø 右对齐

右对齐允许工程设计人员在选择多个图形对象后（必须2个以上的图形对象），点击编辑菜单中对齐项中的

“右对齐”命令或者点击工具按钮中的右对齐按钮 [image] ，或者调出右键菜单，然后点击右键菜单中对齐项中的

“右对齐”命令。这些图形对象会以最右边为基准，往右移动使各个图形对象的右边沿在同一垂直线上。右对齐

前后对照如图4-20所示：

图4-20 右对齐前后对照

Ø 上对齐

上对齐允许工程设计人员在选择多个图形对象后（必须2个以上的图形对象），点击编辑菜单中对齐

项中的“上对齐”命令或者点击工具按钮中的上对齐按钮 [image] ，或者调出右键菜单，然后点击右键菜单中

对齐项中的“上对齐”命令。这些图形对象将会以上边沿最高的图形对象为基准，图形对象会往上移动使

各个图形对象的上边在一水平线上。上对齐前后对照如图4-16所示：

图4-16上对齐前后对照

Ø 下对齐

下对齐允许工程设计人员在选择多个图形对象后（必须2个以上的图形对象），点击编辑菜单中对齐项

中的“下对齐”命令或者点击工具按钮中的下对齐按钮 [image] ，或者调出右键菜单，然后点击右键菜单中对齐项

中的“下对齐”命令。这些图形对象将会以下边沿最低的图形对象为基准，图形对象会往下移动使各个图形对象

的下边在一水平线上。下对齐前后对照如图4-17所示：

图4-17 下对齐前后对照

Ø 垂直居中

垂直居中允许工程设计人员在选择多个图形对象后（必须2个以上的图形对象），点击编辑菜单中对齐项

中的“垂直居中”命令或者点击工具按钮中的垂直居中按钮 [image] ，或者调出右键菜单，然后点击右键菜单中

对齐项中的“垂直居中”命令。这些图形对象会左右移动使各个图形对象的中心在同一垂直线上，这条垂直线

是垂直居中前最左边和最右边的中心垂直线，垂直居中前后对照如图4-18所示：

图4-18 垂直居中前后对照

Ø 水平居中

水平居中允许工程设计人员在选择多个图形对象后（必须2个以上的图形对象），点击编辑菜单中对齐项

中的“水平居中”命令或者点击工具按钮中的水居中按钮 [image] 。这些图形对象会左右移动使各个图形对象的中

心在同一水平线上，这条水平线是水平居中前最上边和最下边的中心水平线。


其它

定义

本章介绍其它的功能使用。

目录

l 调整画面宽高度

l 图库


调节画面宽度与高度

定义

为了让画面显示美观或符合设计需求，需要对画面进行宽度、高度进行调节。

操作

属性概述

n 画面背景设置

l 分辨率：设置画面宽度与高度，宽度和高度的分辨率范围为1~1024。


图库

定义

图库是存储软件工程的图片，根据需求，可选择我们设置好的图片，也可以使用外部图片。

属性

属性概述

n 选择设计好的图片

选择你要选择该图片的目录，点击图片后选择确定或者双击图片就可以选择该图片。

n 自定义图片

在“扩展图库”目录右键选择“新建”，可以建立自己自定义的图片目录

在新建的图片目录右键选择导入也可以选择删除，选择导入即可导入图片

导入图片后，点击图片后选择确定或者双击图片就可以选择该图片。


联系方式

创新 专业 引领 共赢

深圳市显控科技股份有限公司

Shenzhen Samkoon Automation Technology Co.,Ltd

地址：深圳市南山区高新中区深圳软件园一期1栋3楼

Address：Building C6 Hengfeng Industria1

Baoan District, Shenzhen,China.

电话(TEL)：0755—29419068

0755—29419038

传真（FAX）：0755-29455559

E-Mail：samkoon@samkoon.com.cn

网址(Web)：Http://www.samkoon.com.cn


ASCII输入显示器——数据输入

定义

设置ASCII输入显示器的输入方式，当基本选项卡里面设置了允许输入，则出现此选项卡对数据输入进行设置

属性图

属性概述

n 触摸

触摸数值输入显示器，则会弹出键盘

n 位

键盘的弹出受位控制

l 允许输入位地址：存放位地址

n 启用弹出键盘

当主态中设定了自定义键盘，则此选项可勾选，用户可选择设定的键盘进行输入未设定自定义键盘时，此选项不可用，输入调用系统键盘

n 键盘坐标

X坐标：键盘左上角的x坐标。范围为0~480

Y坐标：键盘左上角的y坐标。范围为0~250

数据输入若选择了位控制键盘弹出，当位地址为1时，键盘将自动弹出，若勾选自动复位，

则位地址自动复位到0.


ASCII输入显示器——权限设置

定义

ASCII码的显示和触控受权限控制，包括地址权限和用户组权限。

属性图

属性概述

具体属性的解释，请参考权限设置页

当ASCII码输入显示器在基本页面选择了允许输入的时候，启用触控权限策略可用，否则不可用


数值显示器——数据输入

定义

设置数值输入显示器的输入方式，当基本选项卡里面设置了允许输入，则出现此选项卡对数据输入进行设置

属性图

属性概述

n 触摸

触摸数值输入显示器，则会弹出键盘

n 位

键盘的弹出受位控制

l 允许输入位地址：存放位地址

n 启用弹出键盘

当组态中设定了自定义键盘，则此选项可勾选，用户可选择设定的键盘进行输入未设定自定义键盘时，此选项不可用，输入调用系统键盘

n 键盘坐标

X坐标：键盘左上角的x坐标。

Y坐标：键盘左上角的y坐标。

数据输入若选择了位控制键盘弹出，当位地址为1时，键盘将自动弹出，若勾选自动复位，

则位地址自动复位到0.


数值输入显示器——权限设置

定义

数值输入显示器的显示和触控受权限控制，包括地址权限和用户组权限。

属性图

属性概述

具体属性的解释，请参考权限设置页

当数值输入显示器在基本页面选择了允许输入的时候，启用触控权限策略可用，否则不可用


日期/时间显示器——权限设置

定义

日期时间显示器的显示和触控受权限控制，包括地址权限和用户组权限。

属性图

属性概述

具体属性的解释，请参考权限设置页


时间显示器

操 作

1. 在控件栏中选择 [image] 这个图标，会出现数据显示器的属性设置框我们选择第三个图标，

日期/时间显示，就会出现有关日期/时间显示器的属性设置内容

2. 设置完属性值之后，我们点击确定按钮，鼠标的光标变为十字架，左键点击控件要放置

的位置起点，点下之后同时拖动光标，确定控件的区域大小，松开左键，则绘制出了控件

3. 鼠标左键双击控件或者点击工具栏中的 [image] 图标，则弹出属性设置界面，用户可以修改参数。

目 录

l 基本

l 外观设置


时间显示器——基本

定义

显示系统时间，日期，星期

属性图

属性概述

n 字体

对显示的数值字体和大小进行设置

l 类型：可选择系统中所有的字体类型

l 大小：对显示数值字体大小的设置，范围是5 ~ 128

l 语言种类：可以选择中文或者英文

n 文本属性

设置文本的显示效果

l 无效果：按正常显示，没有任何效果

l 粗 体：显示的值加粗

l 斜 体：显示的值是斜体

l 下划线：显示的值有下划线

n 监控日期/时间

设置时间显示器显示的内容

l 日期：勾选显示当前日期，并有多种格式

l 星期：勾选显示当前星期几

l 时间：勾选显示当前时间，并有多种格式

监控日期/时间可以进行多选，选择要显示的内容。

详细概述

n 日期格式

n 时间格式


时间显示器——外观设置

定义

设置时间显示器的外观，包括外形和字体颜色

属性图

属性概述

n 图片

可以从图库中选择合适的图片作为时间显示器的外形

n 数值颜色

设置显示器中时间的显示颜色，可以从颜色表中选择。

n 数值背景颜色

设置时间显示器的背景颜色，当选择了图片作为外形时，文本背景颜色变为透明。

n 透明度

控件显示背景的透明度，范围是0 到255


什么是RemoteHMI？

定义

RemoteHMI组态软件是深圳市显控自动化技术有限公司Samkoon AK系列触摸屏组态画面开发系统，是集成化的开发环境，有很丰富而且很强大的开发功能。RemoteHMI利用了Windows系统的优点，界面一致性好，简单，菜单的布局接近与Windows操作习惯，易学易用，工程设计人员可以在RemoteHMI中开发适合自己工程使用的组态。它的功能结构特点可以减少开发自动化项目的时间，缩短系统升级和维护的时间，与第三方应用程序无缝集成，增强生产力。

RemoteHMI的功能和特点总结如下：

1. 画面

Samkoon触摸屏系列的颜色达到1677万色，与其他厂家的触摸屏相比，显得非常鲜艳，

在使用RemoteHMI时就可以用鲜艳的颜色来组态，RemoteHMI还配有更大的图库，让

工程设计人员能够更加方便，快捷的设计自己的工程组态。把组态下载到触摸屏去后，

具有和电脑屏幕一样的效果，颜色字体不失真。同时RemoteHMI的操作画面非常简洁明了，

菜单的设计与布局符合Windows操作习惯，设计时吸取了各大画面组态软件和触摸屏组态

软件的优势，把他们融合在一起，能组态出高性能，高质量的工程文件。

2. 功能齐全

RemoteHMI的功能齐全，从基本形状绘图，颜色描绘，文本绘制，系统图库，动画显示，

位图状态变化，趋势图显示，报警控件等这些功能。RemoteHMI更新增了动态圆，

动态矩形，仪表，历史数据收集，地址查找，离线模拟,资料传输，宏指令，多功能键等更

加强大的功能。工程设计人员只需要根据自己的要求和工程特点，进行方案设计和组态，

就能达到您预想的效果。

3. 通信

RemoteHMI提供了与世界各大PLC厂家的通信驱动。如：西门子，三菱，欧姆龙，富士，

松下，施耐德，艾默生等等，涵盖了绝大部分厂家。同时还可以为顾客开发出指定PLC的通

信驱动。Samkoon系列的AK-10.2，AK-7.0，AK-7.0可同时加载两

个通信驱动。

4. 资源

RemoteHMI提供了很丰富的资源。RemoteHMI的图库包含了类如：三维指示灯，三维

按钮，电机，三维罐体，三维管道，电子，棒图等等，并且很多的图形都带有动画属性，

可以设计出逼真的动画效果。支持自定义图库；支持从Windows插入图片。RemoteHMI

还提供了功能丰富的控件，如趋势图和报警控件等等，满足各种组态的需要。


RemoteHMI画面

定义

本章介绍RemoteHMI的画面

目录

l 画面


开关——功能设置

位开关定义

位按钮可以用来操作和显示与触摸屏所连接的设备的位地址 ON/OFF状态，或者1/0状态。位按钮是最基本的，也是最常用的控件。

位开关属性图

位开关属性概述

n 位开关属性

l 位地址：使用位地址来控制开关与其他控件的位地址。

l 操作类型：分为置位、复位、点动、交替。

u 置位：选择“置位”功能，下载到HMI上后，单击该位按钮即可把写入地址的值置成1，即把连接设备的该写入地址置成ON状态，并显示1/ON状态。

u 复位：选择“复位”功能，下载到HMI上后，单击该位按钮即可把写入地址的值置成0，即把连接设备的该写入地址置成OFF状态，并显示0/OFF状态。

u 点动：选择“点动”功能，包含了“按下为1”和“按下为0”这两个功能。当选择的是“按下为1”功能后，下载到HMI上后，当对位按钮进行触控操作时，按住位按钮可把连接设备所写入的地址的值置成1/ON，显示1/ON状态；松开触碰时把所写入地址的值置成0/OFF，显示0/OFF状态；当选择的是“按下为0”功能后，下载到HMI上后，当对位按钮进行触控操作时，按住位按钮可把连接设备所写入的地址的值置成0/OFF，显示0/OFF状态；松开触碰时把所写入地址的值置成1/ON，显示1/ON状态。

u 交替：选择“交替”功能，下载到HMI上后，若当前位按钮的状态为0/OFF时，当对位按钮进行触控操作，触碰该位按钮，把写入地址的值置成1/ON，显示1/ON状态；若当前位按钮的状态为1/ON时，当对位按钮进行触控操作，触碰该位按钮，把写入地址的值置成0/OFF，显示0/OFF状态；状态随触碰依次交替变化。

l 执行方式：当操作类型为“点动”时，执行方式可选。分（按下为0/1）。具体介绍请看点动操作类型的介绍。

字开关定义

字按钮可以对连接设备的数据寄存器进行输入定值，输入数值，递加，递减，对寄存器的数值加减运算等操作。

字开关属性图

字开关属性概述

n 字开关属性

l 字地址：设置字开关的字地址。

l 数据类型：如图

位 长 | 类 型 | 范 围
16位 | 整数 | -32768 ~ 32767
 | 正整数 | 0 ~65535
 | BCD码 | 0 ~ 9999
32位 | 整数 | -2147483648~2147483647
 | 正整数 | 0~4294967295
 | BCD码 | 0~99999999
 | 浮点数 | -9.9e16 ~ 9.9e16

l 操作类型：写入数据、数值加、数值减、连续加、连续减。

u 写入数据：设置好字地址和常数后，点击字开关，就会输出常数。比如：设置好字开关的写入地址为LW0，常数为10；再设置数值显示器的地址为LW0，下载到屏里，点击字开关，数值显示器显示的值就为10。

u 数值加：设置好数据类别，写入地址，常数以及最大值后，每次触控该“字按钮”控件，写入地址所对应的寄存器的值就会在原来的基础之上加上所设置的常数值。因每次触控该按钮，写入地址的值都会加上一个常数，但写入地址的值不能超过你设置的最大值。例如：写入地址是LW1，常数设置为5，最大值为65535。运行后每次单击该“字按钮”控件，LW1的值都会在原来的基础上加上5，但LW1的值最大不能超过65535。

u 数值减：设置好数据类别，写入地址，常数以及最大值后，每次触控该“字按钮”控件，写入地址所对应的寄存器的值就会在原来的基础之上减去所设置的常数值。因每次触控该按钮，写入地址的值都会减去一个常数，但写入地址的值不能低于你设置的最小值。例如：写入地址是LW1，常数设置为5，最小值为0。运行后每次单击该“字按钮”控件，LW1的值都会在原来的基础上减去5，但LW1的值最小不能小于0。

u 连续加：当“延时参数”为0时，该功能和“加”功能相同；如“延时参数”不为0时，在模拟或者屏中，点击该控件，经过“延时参数”设置的时间后，写入地址的值会不停的加上常数值，并写入到写入寄存器中。

u 连续减：当“延时参数”为0时，该功能和“减”功能相同；如“延时参数”不为0时，在模拟或者屏中，点击该控件，经过“延时参数”设置的时间后，写入地址的值会不停的减去常数值，并写入到写入寄存器中。

l 常数：可以选择不同的数据类别，软件为工程设计提供多种数据类别：16/32位正整数，16/32位整数，16/32位BCD正整数和32位浮点数。设常数就是给写入地址写入您所设置的常数值。例如：写入地址为LW1，常数设置为10，则每次触控该按钮时，无论此时LW1的值为多少，LW1的值都被置成常数值10。

画面开关定义

画面按钮主要用于画面的切换、注销用户和弹出窗口等操作。触控设置好后的画面按钮可以使画面/窗口跳转到所设置的画面/窗口上去操作，在跳转的过程中还可以选择是否注销用户。

。

画面开关属性图

画面开关属性概述

n 画面开关属性

l 操作类型：分跳转到下一个画面、跳转到指定画面、打开窗口、关闭窗口。

u 跳转到下一个画面：点击画面按钮，则可跳转至下一个画面。比如有3个画面，画面按钮在画面1，点击则跳转至画面2.

u 跳转到指定画面： 设置好画面名称，点击画面开关则可跳转到指定画面。比如有3个画面，设置画面名称为“画面3”，画面按钮在画面1，点击则跳转至画面3.

u 打开窗口：设置画面名称，点击画面开关按钮则弹出所选定的画面或窗口。

u 关闭窗口：设置画面名称，点击画面开关按钮则关闭所选定的画面或窗口。

u 返回到上一个画面：设置画面名称，点击返回到上一个画面。

l 跳转时注销用户：设置跳转是否注销当前用户（慎选）。

功能开关定义

特殊开关按钮在整个触摸屏中是很重要的控件，通过功能按钮可以很方便快捷的达到各种功能要求。

功能开关属性图

功能开关属性概述

n 功能开关属性

。

l 选择功能：分为背景灯开关、系统重启、设置屏保时间、设置系统时间、切换当前用户、用户管理、触摸声音开关、产品授权、语言切换、屏幕截图、窗口操作、采样数据操作、配方操作、报警操作。

u 背景灯开关：设置功能按钮功能为关闭报警灯，则在触摸屏上触碰该按钮可以关闭触摸屏的背景灯，但是触摸屏仍然会正常工作。若要打开背景灯，只需在触摸屏的屏幕上任一位置触摸一下即可打开背景灯。

u 系统重启：设置功能按钮功能为重新启动，则在触摸屏上触碰该按钮可以重新启动触摸屏。

u 设置屏保时间：设置功能按钮功能为设置屏保时间，则在触摸屏上触碰该按钮会弹出一个窗口，在窗口里可设置屏保时间。

u 设置系统时间： 设置功能按钮功能为设置系统时间，则在触摸屏上触碰该按钮会弹出一个窗口，在窗口里可设置系统时间。

u 切换当前用户：设置功能按钮功能为切换当前用户，则在触摸屏上触碰该按钮会弹出一个窗口，在窗口里可设置用户，进行切换。

u 用户管理：设置功能按钮功能为切换当前用户，则在触摸屏上触碰该按钮会弹出一个用户管理窗口，在窗口里有添加用户、更新用户、删除用户。退出等操作。

u 触摸声音开关：设置功能按钮功能为触摸声音（关闭/打开），使用该功能键可以打开或关闭操作触摸屏时的声音。若当前操作触摸屏发出声音，使用该功能键后，操作触摸屏时不发出声音，反之亦然。

u 语言切换：切换当前语言。

u 屏幕截图：截取当前屏幕的样图。

u 窗口操作：设置好选择类型是打开还是关闭窗口，再设置要操作的窗口，在屏里触动功能按钮时，执行相应的操作。如图

u 采样数据操作：在屏中输入采样数据的组号，删除某一组的采样数据。

u 配方操作：有如下操作

u 报警操作：设置报警声音开关、确认报警、清除报警、清除历史报警数据等操作

u 修改当前用户密码：更改当前用户设置的密码

u 注销当前用户：注销当前使用的账户

u 启动网络服务：启动和设置数据传输端口

u 曲线缩小：趋势图和数据群组缩小

u 曲线放大：趋势图和数据群组放大

u 发邮件：设置报警后发送邮件给设置的邮箱，具体点击链接

u Wifi设置：进入 wifi设置界面

u 启动远程服务：连接屏，使之可以远程监控

u 关闭远程服务：关闭远程连接的屏幕的功能

u 以太网设置：进入以太网设置界面

u 系统设置：进入系统设置界面

u 返回系统桌面：进入Android 原始桌面

l 选择类型：根据选择的功能设置选择类型。

指示灯定义

位指示灯可以用来监视的所连接的设备的位触点ON/OFF状态，并可以在触摸屏上以相应的ON/OFF 状态来显示位触点的状态。如下图：

指示灯属性图

属性概述

n 指示灯功能

l 启用指示灯功能：分双态监视和多态监视。

当用户没有选择监视的时候，位按钮的开关状态不会随触碰控件而改变其值。

l 双态监视：分地址类型、监视地址和是否与操作地址相同等属性。以两种方式进行监视。

u 地址类型：选择是位地址还是字地址。

u 监视地址：根据地址类型，输入相应的地址

当所监视的地址的值为1/ON时，该位按钮显示1/ON状态；当所监视的地址的值为0/OFF时，显示0/OFF状态。当选择的是“监视”时，监视的地址和写入的地址可以不一样。比如当该位按钮选择的是置位功能，触碰该位按钮，可以把写入地址置成1/ON，但如果监视的地址此时状态为0/OFF，则该位按钮显示的是0/OFF状态。一般都选择“监视地址与写入地址 相同”这个选项，这样可以直接反映或者显示你写入的状态值。

u 与操作地址相同：当开关为位开关时，可选择此属性。

l 多态监视：分地址类型、数据类型、监视地址、是否与操作地址相同、状态数、状态条件切换等属性。可以以多种形式进行监视。

u 地址类型：选择是位地址还是字地址。

u 数据类型：包含16/32位整数/正整数，32位浮点数，写入地址和监视（读取）地址的数据类型。

u 监视地址：根据地址类型，输入相应的地址。详细请看双态监视的监视地址。

u 与操作地址相同：当开关为位开关时，可选择此属性。

u 状态数：用户可根据个人需要设置总状态的数目，最多可设置256个状态。即0-255个状态。

u 状态条件切换：分按数值切换、按寄存器的位切换和自定义状态值切换。

当用户选择了此选项的时候，在“自定义状态值”之后会出现一个“定义状态值…”的按钮，如图：


邮件发送功能说明

一、 基本信息

1、 邮件发送环境：发送邮件的屏需要连接到网络。

2、 邮件发送功能接入：开关 à 功能开关 à 发邮件；将发邮件功能按钮拖到画面中即可。其中邮件发送界面如下：

3、邮件发送功能包主要包括以下两个方面：

Ø 发件人、收件人 基本信息录入。

Ø 添加邮件内容（包括：附件）和发送。

二、 发件人、收件人 信息配置：

1、发件人信息配置：点击 à“发邮件”功能开关 à 邮件发送界面 à“设置”按钮。

根据提示进行输入：发件人邮箱， 邮箱登陆密码，邮箱对应的服务器。邮箱地址、密码正确，对应的邮件发送服务器正确，邮件才能发送成功。

其中，常见的邮箱对应的服务器如下：

发件人邮箱 服务器

163邮箱 smtp.163.com

126邮箱 smtp.126.com

QQ邮箱 smtp.qq.com

新浪邮箱 smtp.sina.com

搜狐邮箱 smtp.sohu.com

雅虎邮箱 smtp.mail.yahoo.com.cn

Google邮箱 smtp.gmail.com

HOTMAIL邮箱 smtp.live.com

2、 收件人信息配置：

收件人对应的行 有两个按钮 “添加”、“删除”。

Ø 点击“添加” 可以添加 一个或者多个收件人，一次只能添加一个。点击确定完成添加

Ø 点击“删除” 可以删除 一个或者多个收件人。点击确定完成删除。

三、 添加邮件内容和发送

1、 添加邮件发送内容，包括如下两部分。

Ø 添加文字内容。点击主界面输入框，即可以添加邮件内容。

Ø 添加附件。目前支持的附件为：报警数据、配方数据、历史采集数据、留言板信息。 添加步骤：点击“添加附件”按钮 à 进入添加附件界面 à 选择附件内容。（其中，报警数据可以设置“起始时间”、“结束时间”。如果设置时间，那么发送选中时间段内容；不设置时间，那么将发送所有的内容）。

2、 发送：在主界面点击发送按钮。添加的文字信息和选中的附件内容，将会发送到目的邮箱中，发送完成，对话框会自动消失。

四、 邮件发送失败的可能原因：

1、没有网络；

2、发件人、收件人信息错误（包括发件人邮箱、密码、smtp服务器和收件

人邮箱）；

3、邮箱没有开启smtp服务，很多公共邮箱需要手动开启smtp服务，具体

的开启方法可以在网上寻找；

4、发送出去的邮件，被视为垃圾邮件，被屏蔽了；

5、部分邮箱附件的名称为中文名称，也不能成功发送。


系统设置

目录

l 主机管理

l 主机外设

l 组态工程